Multicast problem with dynamically created vlans

  • 0
  • 1
  • Question
  • Updated 6 days ago
  • (Edited)
Hi,
following scenario:
- two AccessSwitchstacks X450-G2 (22.4), each connected with an MLAG to a pair of Summit X620 Distributionswitches. (X450 <=> X620 <=> X450)
- VLAN A is configured in all Switches
- VLAN B is configured in X620 and dynamically created (via Netlogin) in X450 (f.e. SYS_VLAN_123)

In VLAN B Multicast-using devices (Bonjour in this case) can not see each other if they are not on the same access switch.

Using "show mcast cache" I see the Uplink Port towards the distribution switch (port 1:49) is only shown in configured VLANs and not in dynamically created VLANs.
f.e. configured VLAN A :
snoop 224.0.0.18        172.16.128.3         43   A
Vlan Port Vid
A 1:22 1460
1:23 1460
2:34 1460
2:38 1460
1:49 1460
dynamically crated VLAN B (1155):
snoop 224.0.0.1         141.45.139.151       81   SYS_VLAN_1155
Vlan Port Vid
SYS_VLAN_1155 1:23 1155
1:24 1155
2:3 1155
2:4 1155
Everything is tagged on Uplink Ports. So I think we have a problem with Multicast packets over Uplinks in dynamically created VLANs. The Switches are running Multicast default configuration. Is there something I have to configure  für dynamic VLANs?




Photo of htw

htw

  • 1,256 Points 1k badge 2x thumb

Posted 6 days ago

  • 0
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,972 Points 20k badge 2x thumb
Photo of htw

htw

  • 1,256 Points 1k badge 2x thumb
Yes, this is the method we use to add dynamically created VLANs to our Uplink Ports
show config vlan
...
configure vlan dynamic-vlan uplink-ports add ports 1:49
And those VLANs are affected with our multicast problems.
(Edited)