Multicast traffic doesn't pass through the core

  • 0
  • 1
  • Problem
  • Updated 7 months ago
  • Solved
Hi, evebody,

I have a very simple configuration where Sender is on X430 (VLAN9) and Receiver is on other X430 (VLAN26). Both X430 are connected through X670 (it's core switch).

ipforwarding and ipmcfowarding is enabled on X670 for both VLANs.

I got queries from both VLANs for right groups (I've tried to do vice versa) - I mean X670 sees requests from X430 for my groups. There are no any ACLs on vlans anywhere. TTL set is 10.

The problem is the Receiver doesn't get multicast traffic for a requested groups. Both laptops are Windows PCs. 

How can I fix the problem?

Many thanks in advance,

Ilya
Photo of Ilya Semenov

Ilya Semenov

  • 4,610 Points 4k badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of David Choi

David Choi, Employee

  • 1,966 Points 1k badge 2x thumb
Hi Ilya,

Since the source and receiver are located in different VLANs, you need a multicast protocol such as PIM. Or you can also consider to use the MVR (Multicast VLAN Registration) over the different VLAN for simple implement.

Please refer the EXOS user guide for further details.

Regards,
David
Photo of Ilya Semenov

Ilya Semenov

  • 4,610 Points 4k badge 2x thumb
I've found thus:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-To-Configure-MVR?_ga=2.126852494.20184...

Could you please explain me what means "nlri <IP>/<MASK>" here:

entry mvr_adress_range {if match all{
nlri <IP>/<MASK> ;
} then {
permit;
}
}
Photo of David Choi

David Choi, Employee

  • 1,966 Points 1k badge 2x thumb
The NLRI IP address and mask means the multicast group address (e.g. 239.1.1.1/32). There are two types of MVR, static and dynamic. So the policy can be used in differently:
  • the action is "permit" or "deny"
  • applied to static MVR or dynamic MVR
I hope following section could be helpful:
https://documentation.extremenetworks.com/exos_22.4/EXOS_21_1/IP_Multicast/c_mvr-sample-configuratio...

Regards
Photo of Ilya Semenov

Ilya Semenov

  • 4,610 Points 4k badge 2x thumb
Hi, David,

thanks for your reply! This is really very strange, because 2 years ago everything worked without PIM/MVR in this organization. 

Update: MVR requires ipmcforwarding to be disabled. But I repeat, it worked without MVR.