NAC GW loses resolved IP

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
We have a captive wireless clients, which are registering by the captive portal running on a NAC GW. When the client ends the registration process, I can see the resolved IP address of the client in the NAC console, but after a short time, about 10-20 seconds the IP address is gone and I get a "MAC to IP resolution Failed" in the Extended State and "Unable to resolve IP address using SNMP, NetBIOS, or DHCP" in the State Description fields. But when I check the clients report on the EWC console, the client's IP is shown.
Photo of Gabriel Bagita

Gabriel Bagita

  • 550 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Andre Brits Kannemeyer

Andre Brits Kannemeyer

  • 5,010 Points 5k badge 2x thumb
If the EWC is acting as your DHCP server, ensure that you have enabled the NAC integration in the Global Tab.
If you are using a external DHCP server, add the NAC as a second IP helper address in the routed interface.
Photo of Gabriel Bagita

Gabriel Bagita

  • 550 Points 500 badge 2x thumb
EWC is not a DHCP server. It is a default GW for the vlan the client is connected, so I can't set a relay server on it.
Photo of Karthikeyan M

Karthikeyan M, Systems Engineer

  • 546 Points 500 badge 2x thumb
Hi,

Follow the config checks mentioned in this article. Configuring DHCP helper IP address as NAC in your default gateway may solve the problem.
https://gtacknowledge.extremenetworks.com/articles/Solution/NAC-IPhost-resolution-failing-on-some-cl...
(Edited)