Need help understand what to do, my Core switch is spamming "Warning" recieved IGMPV1 query on Vlan ***?

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hi my Core switch recently started to display IGMPv1 warning messages and I have no idea on how to troubleshoot it. What I did do was conduct a nslookup on each IP that was populating on the IGMPv1 warning and they were coming from other IDF stacks. When I logged in into each IDF stacks, I did not see similar warnings, anyone have any idea?
Photo of Arison Mercado

Arison Mercado

  • 442 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Brian Mankin

Brian Mankin

  • 94 Points 75 badge 2x thumb

Hello Arison.  Please paste a copy of the output from the console.  If you could reboot the switch and paste the full output from startup, that might be useful.

Photo of Arison Mercado

Arison Mercado

  • 442 Points 250 badge 2x thumb
I would like to but I have to wait for the weekend because this switch managers several k-12 sites. But I can grab that information for you. Would you like a show log command? or show tech?
(Edited)
Photo of Dorian Perry

Dorian Perry, Employee

  • 2,300 Points 2k badge 2x thumb
Hi Arison,

Is this the message your are receiving?

<Warn:IPMC.Warning> Warning: received IGMPv1 query on vlan *** configured for IGMPv2 from x.x.x.x

See Knowledge Article:
<Warn:IPMC.Warning> Warning: received IGMPv3 query on vlan vlanx configured for IGMPv2 from x.x.x.x logs

Although this article mentions IGMPv3 and v2, I believe it is the same behavior. 
Photo of Arison Mercado

Arison Mercado

  • 442 Points 250 badge 2x thumb
Those are the exact messages I'm receiving and they're coming from the same brand of switches that I've always had. I'll look into that article to see what I can find. 
Photo of Arison Mercado

Arison Mercado

  • 442 Points 250 badge 2x thumb
I reviewed it but it doesn't explain on how to resolve these messages.
Photo of Dorian Perry

Dorian Perry, Employee

  • 2,300 Points 2k badge 2x thumb
The article offers two options:

1. Enable [IGMPv1] on the VLAN.

Command: enable igmp vlan <VLAN_NAME> IGMPv1
http://documentation.extremenetworks.com/exos_commands/EXOS_All/EXOS_Commands_All/r_enable-igmp.shtm...

or

2. Disable [IGMPv1] on the devices that are sending the packets.
Photo of Christoph

Christoph

  • 1,842 Points 1k badge 2x thumb
Devices in your network like to join a multicast conversation. They query for it.
Probably, your router recognizes these queries but can not handle it.

Except a different configuration, in default your switches don't care about multicast queries. Because it's a Layer-3 communication. So switches will not log these kind of messages.
(Edited)