Need help : Port 80 is not closed.

  • 0
  • 1
  • Question
  • Updated 5 years ago
Create Date: Mar 13 2013 3:06AM

Hi everyone, I have a Extreme Summit x450A..

I was trying to disable the http web access to the switch since I am using https to access to the switch.

However, after I issued "disable web http" command, save configuration and restarted the switch. I am still able to access to the login page through http://switch_ip

Just that it prompts http request error when I try to login and view the detail.

My question is.. how to totally closing port 80 down because I dont even wan the web login page accessible.

Thanks

(from hengchuen)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Mar 13 2013 8:11PM

Very strange - what version of XOS are you running? It could be a bug, or there could be something else at work. At any rate you could make an ACL that blocks port 80 on the interface:

entry block-80 {
if {
destination-address swi.tch.i.p/32 ;
destination-port 80 ;
} then {
deny;
}
}


(from Ansley_Barnes)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Mar 13 2013 8:46PM

Very Strange can you do a show man after you disable it to verify that it is off?  Before you restart it try and access it via web to make sure it is down.

Thanks
P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Mar 14 2013 8:06AM

May be you must upgrade that switch firmware, because i use 15.x always ok (deny access) but version 12.6 will fail (web can be access)
(from Hsu_LiPing)

This conversation is no longer open for comments or replies.