netlogin: using the default vlan as the netlogin guest-vlan

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
  • (Edited)
Hello,

I am trying to setup dymanic vlans at a site and would like to have non dot1x clients fall back to vlan default . When this is set after the timeout they are able to join vlan default for about 20-30 seconds then attempt to authenticate again and this will continually loop. Everything works normally when I set the guest vlan to any other. Is this normal behavior ?
netlogin config:
configure netlogin vlan netlogin-guest
enable netlogin dot1x 
enable netlogin dot1x guest-vlan ports 5:47-48
enable netlogin authentication failure vlan ports 5:47-48
enable netlogin authentication service-unavailable vlan ports 5:47-48
configure netlogin dot1x guest-vlan Default ports 5:47-48
configure netlogin authentication failure vlan Default ports 5:47-48
configure netlogin authentication service-unavailable vlan Default ports 5:47-48
enable netlogin ports 5:47-48 dot1x 
configure netlogin ports 5:47 mode port-based-vlans
configure netlogin ports 5:47 no-restart
configure netlogin ports 5:48 mode port-based-vlans
configure netlogin ports 5:48 no-restart

Thanks,
Photo of Jordan Bagnell

Jordan Bagnell

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Burak Kale

Burak Kale

  • 280 Points 250 badge 2x thumb
Hi Jordan;


I am not sure if it is the solution ,but stp is playing an important role on configurations like this. Please change your stp mode to rstp (802.1w) .Because you know it is operating so much faster than stp (802.1d). And i experience same problem with an another vendor , and fixed it with stp.


Also i suggest you to use a different vlan than default for your configuration.


Regards,


Burak.
(Edited)