NetSight Device Up alarms without any Device Down

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
The problem I am having is that we are receiving Device Up alarms on devices which have not produced any Device Down alarms??

The traps Poll interval is 15 seconds, the timeout is 30 seconds and the option to "Send Down Event on timeout ONLY" is selected.

The devices that generate the Device Up alarm have not actually gone down so these are false positives but the question is why?

Device Down is generated by the "device status change - Contact Lost"

Device Up is generated by the "device status change - Contact Established"

Here are screenshots of all the SNMP polling settings.










Is it something to do with the "Send Down Event on timeout ONLY"??

Regards
Ezeddean
Photo of Ezeddean Osman Almansouri

Posted 3 years ago

  • 0
  • 1
Photo of Thomas, Frank

Thomas, Frank, Employee

  • 1,902 Points 1k badge 2x thumb
I once had this issue, the exact reason that this is happening is that you have "Send Down Event on timeout ONLY" is selected.
A device may have a general snmp error which will not cause device down. I ended up creating a secondary alarm looking for a particular message from console log. 


To verify the theory, you can find/filter the console log for SNMP Error: General Error.
Do you mean by Console Log, the console tab in the NetSight console window? Please see below image.



As there are no alarms or logs generated which indicate an SNMP error or a log of any sort, am I right in believing that I will just have to live with these device up alarms?
Thanks for the reply Thomas, much appreciated. I couldn't see any SNMP errors in the logs though that I could use to create a custom SNMP error alarm for? Any idea's?
Photo of Thomas, Frank

Thomas, Frank, Employee

  • 1,902 Points 1k badge 2x thumb
What I would set up a custom criteria alarm that matches all.

Contains                                  SNMP Error
Does not contain                     Timeout\[4098\]