Netsight doesn't create a link on the map with IBM PureFlex

  • 0
  • 2
  • Question
  • Updated 2 years ago
  • Answered
Hello, everybody!

I have added an IBM Pureflex EN4093 switch to Netsight 7.0.3 over SNMP. I can see Model, version, and many others SNMP's IDs, but I can't see link between my Extremes and Pureflexes in Oneview (in Maps).  I have got links between Extremes and CISCOs, but there is a problem with IBM Pureflex.

The Pureflex is connected to X670 stack. LLDP is turned on on both sides. From X670 I see the following info about Pureflex:

LLDP Port 3:20 detected 1 neighbor

  Neighbor: A8:97:DC:5E:55:00/46, age 20 seconds

    - Chassis ID type: MAC address (4)

      Chassis ID     : A8:97:DC:5E:55:00

    - Port ID type: Locally assigned (7)

      Port ID     : "46"

    - Time To Live: 120 seconds

    - Port Description: "EXT4"

     - System Name: "PF1-SW1"

    - System Description: "IBM Flex System Fabric EN4093R 10Gb Scalable Switch, IBM Networking OS: version 7.8.5, Boot image: version 7.8.5"

    - System Capabilities : "Bridge, Router"

      Enabled Capabilities: "Bridge, Router"

     - Management Address Subtype: IPv4 (1)

      Management Address        : 10.10.0.77

      Interface Number Subtype  : ifIndex (2)

      Interface Number          : 128

      Object ID String          : "null"

    - IEEE802.1 Port VLAN Identifier: 1

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 1

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 250

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 9

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 10

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 11

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 13

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 7

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 12

    - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 14

     - IEEE802.1 Port & Protocol VLAN

      Capability/Status: Incapable, Enabled (0x02)

      PPVID Reference  : 251

    - IEEE802.1 VLAN Name: "Default VLAN", VLAN ID: 1

    - IEEE802.1 VLAN Name: "VLAN 250", VLAN ID: 250

    - IEEE802.1 VLAN Name: "VLAN 9", VLAN ID: 9

    - IEEE802.1 VLAN Name: "VLAN 10", VLAN ID: 10

    - IEEE802.1 VLAN Name: "VLAN 11", VLAN ID: 11

    - IEEE802.1 VLAN Name: "VLAN 13", VLAN ID: 13

    - IEEE802.1 VLAN Name: "VLAN 7", VLAN ID: 7

    - IEEE802.1 VLAN Name: "VLAN 12", VLAN ID: 12

    - IEEE802.1 VLAN Name: "VLAN 14", VLAN ID: 14

    - IEEE802.1 VLAN Name: "VLAN 251", VLAN ID: 251

    - IEEE802.1 Protocol Identity: ""

    - IEEE802.3 MAC/PHY Configuration/Status

      Auto-negotiation       : Not Supported (0x00)

      Operational MAU Type   : 10GigBaseSR (36)

    - IEEE802.3 Power via MDI

      Port Class           : Powered Device (PD)

      MDI Power Support    : Not Supported

    - IEEE802.3 Link-aggregation

      Capability/Status : Capable, Enabled (0x03)

      Aggregated Port ID: 65 (0x00000041)

    - IEEE802.3 Maximum Frame Size: 1522 bytes

    - Unknown organizational specific TLV: Length=7 bytes, OUI=0018B1

      HEX Dump [000]: 00 18 B1 01 10 00 00


Here is my map:



Please, let me know how may I solve the issue?

Many thanks in advance, Ilya

Photo of Ilya Semenov

Ilya Semenov

  • 4,610 Points 4k badge 2x thumb

Posted 2 years ago

  • 0
  • 2
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
Right click and click "refresh (rediscover)".  Sometimes that fixes it for me.  But then again, I have never had a map with anything but Extreme equipment.
Photo of Ilya Semenov

Ilya Semenov

  • 4,610 Points 4k badge 2x thumb
Hello, Jeremy!

This is fun. I've tried. I've waited about 24 hours. Still nothing.
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,908 Points 5k badge 2x thumb
Ilya,

I lately noticed a similar issue where some device added to the maps sends LLDP chassis ID other than MAC address might bring similar situation (links will not be created)

I believe this would be fixed in 8.0, To confirm if you are hitting the same issue can you try the steps mentioned in this article and see if you can find a non mac LLDP chassis ID?

https://gtacknowledge.extremenetworks...