Netsight don't report a defect fan of a X670

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved

Netsight don't report a defect fan of a X670 (firmware 16.1.2.14)

In the log of the switch I noticed a defect fan.

If I query the switch with the MIB tools I see that all fans are operational true.

But log file:

Switch, Code 5: Fan tray 3, fan #5, has failed. RPM (0) is out of operating range which is at or above 2000.

Photo of Johan Hendrikx

Johan Hendrikx

  • 3,804 Points 3k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
Hello Johan.

if SNMP shows operational then Netsight will show no error. The switch should send a trap/notification  to NetSight and then Netsight would see the Fan problem.
This could be a short problem on that fan, does show fans show fan #5 also at 0 rpm  ?
If it is, and snmp reports fan status good there is a mismatch between snmp and real status and it should be fixed in EXOS. (maybe already fixed in newer version?)
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
Hello Johan,

there are quite some known issue's with fan traps not being send, I wonder if you upgrade to the lastest EXOS version if it does report the right status ?
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,804 Points 3k badge 2x thumb

It running on the latest firmware (16.1.2.14)  or is there an other one?

Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
There is already 16.1.4.2-patch1-3 and 16.2.1, but I did not find any known issue's about fan problems in there related to X670.
You can create a case to have this investigated more.
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,804 Points 3k badge 2x thumb
Oscar, thanks.
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,804 Points 3k badge 2x thumb

I see that for the X670-G2 there is also a 22.1

I will upgrade the switch with this firmware