NetSight Traps: unable to find events in log file

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
Since upgrading to NetSight we have lost the ability to log our trap events.  Prior to the upgrade, the traps were working very well.   After the upgrade the only event information shown in the traps window shows "Unable to find events in log file".  I have added the users to the snmpd.conf file and restarted the trap service without any change.

When I view the snmptrapd logs, all that is present is the message "Warning: no access control information configured.  This receiver will *NOT* accept any incoming notifications."  The syslog logs are working fine, but not the traps.

The server is running Windows Server 2008 with SP2, and Java was updated from 6 to 7.

Is there an additional configuration that needs to be applied to get the traps working again?
Photo of Mike Ladach

Mike Ladach

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Bob Maheu

Bob Maheu, Employee

  • 840 Points 500 badge 2x thumb
Official Response

The following tech note should address this issue:

15029: NetSight - Traps not Being Received After Upgrade to version 4.4
Title:NetSight - Traps not Being Received After Upgrade to version 4.4
Article ID:15029

NetSight Console

Upgrade to version 4.4 was performed.

Traps are no longer being received in NetSight Traps view.

Code missing to make sure the trap file and the SNMP mode is correct after restoring files on an upgrade.

Upgrade to NetSight Suite version 5.0 or higher.
Release notes state, in the 'Console Issues Addressed' section:
Resolved an upgrade problem that caused the trap service to not process traps in some cases. 920482

Pre-upgrade workaround:
1.  Start NetSight Console.
2.  Select Tools -> Options -> Suite Options -> Advanced SNMP settings.
3.  Check the option to use NetSNMP.
4.  Save and restart the server when asked.

Edit the file /NetSight_Install_Path/NetSight/appdata/snmptrapd.conf.

Make sure that the first uncommented line is:

disableAuthorization yes

If it is not please add it and then start the SNMP trap service.