Obtaining IP address failed

  • 0
  • 1
  • Question
  • Updated 1 month ago
  • Answered
Hi,

I have adopted AP7502 to wing controller VX9000 and also configured SSIDs and mapped to Radios. Now broadcasting is getting but, when I log in to created SSIDs showing error-obtaining IP address failed.
Photo of Niyas

Niyas

  • 982 Points 500 badge 2x thumb

Posted 2 months ago

  • 0
  • 1
Photo of Christoph S.

Christoph S., Employee

  • 3,450 Points 3k badge 2x thumb
1 - Is the DHCP server in the same broadcast domain?
2 - Have you properly mapped the VLAN to the WLAN?
3 - If you have more than one vlan, have you allowed those through the ge1 port?
4 - Is the AP set as a DHCP client and if so, is it pulling an IP address?
5 - Can you ping the DHCP server from the AP itself?
6 - Are the same VLANs allowed through the switchport the AP is connected to. 

Assign a static IP address on the wireless client, connect to your wlan and ping the DHCP server, is the ping successful?

In other words, start by checking the route starting from the wireless client all the way to the DHCP server and make sure all are properly mapped and allowed through all ports. 
Photo of Niyas

Niyas

  • 982 Points 500 badge 2x thumb
Hi Christoph,

our network is running with DHCP, I have configured WLAN in the controller.i have doubts in VLAN mapping to WLAN.my internet VLAN is 1.currently I have enabled virtual interface as a VLAN 1 in both controller and AP.


Thank you
Niyas P
Photo of Niyas

Niyas

  • 982 Points 500 badge 2x thumb
Hi,

My internet VLAN is 1, I have created a new SSID with VLAN 1, the internet is getting but when I try to access other SSID's with different VLANs, the internet is not getting.


Thanks
Niyas P
Photo of Christoph S.

Christoph S., Employee

  • 3,450 Points 3k badge 2x thumb
Are wireless clients connecting to wlans mapped to VLANs other than VLAN1 pulling an IP address?

1 - Access every wlan and in the vlan assignment field under basic configuration make sure you have entered the correct vlan
2 - In system profile, under Interface > Ethernet ports > ge1, make sure the port is set to Trunk and all vlans are listed in the allowed vlans field
3 - On your switch, make sure the same vlans are allowed on the ports the APs are connected to. 
Photo of Niyas

Niyas

  • 982 Points 500 badge 2x thumb
Dear Christoph,

I have created WLAN with VLAN 34, when I try to connect WLAN,showing IP address unavailable.


Thanks
Niyas
Photo of Christoph S.

Christoph S., Employee

  • 3,450 Points 3k badge 2x thumb
Do you have these same vlans on your corporate network? 

In short, the wlan should be mapped to the vlan, vlans allowed through the ge1 port on the AP, vlans allowed through the switchport the AP is connected to, VLANs created on and traffic managed by router. 

which part is missing?
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 50,004 Points 50k badge 2x thumb
the router is missing - see below post
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 50,004 Points 50k badge 2x thumb
Is there even a router that routes between the different VLANs ?
Photo of Niyas

Niyas

  • 982 Points 500 badge 2x thumb
NO