Option 150 in DHCP for TFTP

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
hi every one,
Marry Xmas and advance happy new year.
 I am using Extreme summit X460 G2 core switch, can i configure option 150 in DHCP for assigning TFTP IP for PABX.? I have tried [configure vlan VOICE dhcp-option code 150 string "10.X.X.X"] the following command but the IP phones are not accepting the IP address from DHCP. Any other option is available?
Photo of Abdul Raheem

Abdul Raheem

  • 458 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Ram

Ram, Employee

  • 1,450 Points 1k badge 2x thumb
Hello Abdul Raheem,

As per the  RFC, I could see the TFTP Server Address Option for DHCPv4 in use is 150.

Please clarify the following information to make us understand where the problem lies:

1. Which vlan is having DHCP ip address allocation issue?
2. Which vlan, port the clients are connected to? Are all clients on different vlans having the same issue?
3. Is this a new setup? If not, what was the latest change done?
4. How are the clients connected to this switch? Directly or via any other switch?
5. Are clients on other vlans able to retrieve an ip address?
6. Client on particular port of the vlan is having an issue or the issue is generic to the particular vlan.

If you send us a "show tech" output from the switch that you have been testing with, and the DHCP server config we can take a look at them and see if anything stands out as a problem.

Please check the below articles for your reference:
https://gtacknowledge.extremenetworks.com/articles/How_To/Troubleshooting-DHCP-issues

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-Bootprelay

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-the-DHCP-server-on-a-VLAN-in-EXOS
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Can you please try the below command set and check:

configure vlan <vlan name> dhcp-options code 176 string 
Photo of Abdul Raheem

Abdul Raheem

  • 458 Points 250 badge 2x thumb
Dear Ram

Thank you very much for your valuable time. Please find my feed back.

1. Which vlan is having DHCP ip address allocation issue?

Ans:- It is for Voice Vlan
2. Which vlan, port the clients are connected to? Are all clients on different vlans having the same issue?

Ans:- the ports connected to Voice Vlan only.
3. Is this a new setup? If not, what was the latest change done?

Ans:- yes this is a new setup done for Cisco IP phones. And the DHCP is configured in our Core Switch.
4. How are the clients connected to this switch? Directly or via any other switch?

Ans:- Cisco IP phones
5. Are clients on other vlans able to retrieve an ip address?

Ans:- For other vlans there is no DHCP server.
6. Client on particular port of the vlan is having an issue or the issue is generic to the particular vlan.

Ans:- Let me elaborate this issue. [Our client has got Cisco IP phones from the ISP vendor. There PABX is some were remotely kept which we don’t know. For testing from the PABX vendor side they have bought separate Cisc 3560 switch and configured the DHCP for Voice vlan. They assigned the command in there DHCP “option 150 ip 10.X.X.X” for which the mentioned IP is there TFTP server. The cisco IP phones got registered and they were working fine.

Now I have configured the DHCP in our Core switch for Voice vlan and assigned the command “configure vlan VOICE dhcp-option code 150 string "10.X.X.X"”.  at that time the IP phones were not able to get the IP from DHCP. Then I just changed the command to “configure vlan VOICE dhcp-option code 66 string "10.12.1.130"” then the Phones were able to receive the IPs with the TFTP server IP but the IP phones were not registering like what the vendor had configured from there Cisco switch.

 

So is there any alternate option in EXOS for the cisco command “option 150 ip 10.X.X.X”?

  
Photo of Abdul Raheem

Abdul Raheem

  • 458 Points 250 badge 2x thumb
Dear Tripathy

 I will try the following command and let you know

configure vlan <vlan name> dhcp-options code 176 string 

Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 44,984 Points 20k badge 2x thumb
Have you tried the config with "ip" instead of "string" ?

X430-48t.2 # configure vlan "Mgmt" dhcp-options code 150 ipaddress ?
<ipaddress1>    IPv4 address
(Edited)
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
I agree with Ronald here. The string here means the ipv4 address which you need to manually mention rather applying the string command. Because this would always throw error.

Please find below the two option codes for DHCP 150 and 176 with the proper command sets:


* pe1syd5_10_2_1_5.1 # configure vlan "mgmt" dhcp-options code 176 ipaddress ?
  <ipaddress1>    IPv4 address
* pe1syd5_10_2_1_5.1 # configure vlan "mgmt" dhcp-options code 150  ipaddress ?
  <ipaddress1>    IPv4 address  

So please try them and check if this fetches ip from DHCP.
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Do let us know once you have time to check the above command sets if provides you the desired result.
Photo of Abdul Raheem

Abdul Raheem

  • 458 Points 250 badge 2x thumb
Dear Priya 
thank you very much for your time.
I have tried the commands. when we use the code 150 and 176 I am not able to get the IPs to client phones. but I am able to receive the IP to my laptop when I connect to Voice Vlan port. 
I just asked the client to get Cisco 3560 switch and they got it, and configured what the Cisco IP phone vendors recommended for the DHCP in that and made as the gateway for the voice vlan.

Now all the phones are registered to the there PABX and which are connected to our extreme switch.  

Once again thank you all for your valuable support.
 
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Thank you Dear Abdul for updating everyone on this thread and it is  nice to know the issue is resolved now. Going forward let us wind off this  thread discussion and wishing you a very very happy and prosperous new year 2017 in making and may bring all the happiness and joy in your future life.