OSPF Stub between EOS and EXOS not updating routing table

  • 0
  • 1
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Hi,

Have a OSPF issue that I must be missing something obvious. Basically I have some EXOS devices activing as the core OSPF backbone area. At the edge I am using a EOS C5 switch configured as an OSPF Stub area.

The two have created a neighbourship between them, and I can see this in the LSDB tables. 

The problem is I can't see the routes from the edge showing up on the core. This is the one I'm interested in at the moment:

172.20.0.254 255.255.255.0

Here is a quick diagram:



Here is the OSPF config on Core 1 (only one connected at the moment), the points of interest are via the P2P VLAN "OSPF-Col-BSD-CEF" and area 172.20.192.254 :

configure ospf routerid 172.20.207.62
enable ospf
enable ospf export static cost 2 type ase-type-1
create ospf area 172.20.192.254
configure ospf area 172.20.192.254 stub nosummary stub-default-cost 10
configure ospf add vlan Core1-To-Core2 area 0.0.0.0 link-type point-to-point
configure ospf vlan Core1-To-Core2 priority 0
configure ospf add vlan Core1CEF-LgcyCEF area 0.0.0.0 link-type point-to-point
configure ospf vlan Core1CEF-LgcyCEF priority 0
configure ospf add vlan Cores-To-Cores area 0.0.0.0
configure ospf vlan Cores-To-Cores priority 130
configure ospf add vlan Mgmt-CEF-Core1 area 0.0.0.0 passive
configure ospf vlan Mgmt-CEF-Core1 priority 0
configure ospf vlan MLAG-ISC priority 0
configure ospf add vlan OSPF-Col-BSD-CEF area 172.20.192.254 link-type point-to-point
configure ospf vlan OSPF-Col-BSD-CEF priority 10

Here is the config on the edge (only configured interface VLAN 101 for now for OSPF, as well as the P2P's):

interface vlan 101
ip address 172.20.0.254 255.255.255.0
ip ospf areaid 172.20.192.254
ip ospf enable
no shutdown
interface vlan 201
ip address 172.20.65.254 255.255.255.0
no shutdown
interface vlan 310
ip address 172.20.128.254 255.255.255.192
no shutdown
interface vlan 320
ip address 172.20.144.254 255.255.255.192
no shutdown
interface vlan 330
ip address 172.20.160.254 255.255.255.192
no shutdown
interface vlan 340
ip address 172.20.176.254 255.255.255.192
no shutdown
interface vlan 999
ip address 172.20.192.254 255.255.255.192
no shutdown
interface vlan 2001
ip address 172.20.248.1 255.255.255.252
ip ospf areaid 172.20.192.254
ip ospf enable
no shutdown
interface vlan 3001
ip address 172.20.249.1 255.255.255.252
ip ospf areaid 172.20.192.254
ip ospf enable
no shutdown
!
router id 172.20.192.254
router ospf 1
area 172.20.192.254 stub no-summary

The routing table on EOS shows the VLAN 101 and the P2P VLAN 2001 are up:

Col-BSD(su)->router#show ip route
Codes: C - connected, S - static, R - RIP, O - OSPF, IA - OSPF interarea
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       E - EGP, i - IS-IS, L1 - IS-IS level-1, LS - IS-IS level-2
       * - candidate default, U - per user static route
C    172.20.0.0/24 [0/1] directly connected, Vlan 101
C    172.20.192.192/26 [0/1] directly connected, Vlan 999
C    172.20.248.0/30 [0/1] directly connected, Vlan 2001

Col-BSD(su)->router#show ip ospf interface
Vlan 101
  Internet Address 172.20.0.254  Mask 255.255.255.0, Area 172.20.192.254
  Router ID 172.20.192.254, Cost: 10  (computed)
  Transmit Delay is 1 sec, State designated-router, Priority 1
  Designated Router id 172.20.192.254, Interface Addr 172.20.0.254
  Backup Designated Router id 0.0.0.0,
  Timer intervals configured, Hello 10, Dead 40, Retransmit 5
Vlan 2001
  Internet Address 172.20.248.1  Mask 255.255.255.252, Area 172.20.192.254
  Router ID 172.20.192.254, Cost: 10  (computed)
  Transmit Delay is 1 sec, State designated-router, Priority 1
  Designated Router id 172.20.192.254, Interface Addr 172.20.248.1
  Backup Designated Router id 172.20.207.62,
  Timer intervals configured, Hello 10, Dead 40, Retransmit 5
Vlan 3001
  Internet Address 172.20.249.1  Mask 255.255.255.252, Area 172.20.192.254
  Router ID 172.20.192.254, Cost: 10  (computed)
  Transmit Delay is 1 sec, State Err, Priority 1
  Designated Router id Err, Interface Addr 172.20.249.1
  Backup Designated Router id Err,
  Timer intervals configured, Hello 10, Dead 40, Retransmit 5

Routing table on EXOS, but its not showing the subnet 172.20.0.254 255.255.255.0 via OSPF-Col-BSD-CEF:

Col-Core1.68 # show iproute
Ori  Destination        Gateway         Mtr  Flags         VLAN       Duration
#d   172.20.207.0/26    172.20.207.62   1    U------um--f- Mgmt-CEF-Core1 0d:2h:3m:4s
#oa  172.20.207.64/26   172.20.251.242  11   UG-D---um--f- Core1-To-Core2 0d:1h:13m:56s
#oa  172.20.207.128/26  172.20.250.243  12   UG-D---um--f- Cores-To-Cores 0d:1h:13m:52s
#oa  172.20.207.192/26  172.20.250.243  13   UG-D---um--f- Cores-To-Cores 0d:1h:13m:52s
#d   172.20.248.0/30    172.20.248.2    1    U------um--f- OSPF-Col-BSD-CEF 0d:1h:42m:33s
#d   172.20.250.224/30  172.20.250.225  1    U------um--f- Core1CEF-LgcyCEF 0d:2h:3m:4s
#oa  172.20.250.228/30  172.20.251.242  11   UG-D---um--f- Core1-To-Core2 0d:1h:13m:56s
#oa  172.20.250.232/30  172.20.250.243  12   UG-D---um--f- Cores-To-Cores 0d:1h:13m:52s
#oa  172.20.250.236/30  172.20.250.243  13   UG-D---um--f- Cores-To-Cores 0d:1h:13m:52s
#d   172.20.250.240/29  172.20.250.241  1    U------um--f- Cores-To-Cores 0d:2h:3m:4s
#d   172.20.251.240/30  172.20.251.241  1    U------um--f- Core1-To-Core2 0d:2h:3m:4s
#oa  172.20.251.244/30  172.20.250.243  3    UG-D---um--f- Cores-To-Cores 0d:1h:13m:52s
#d   172.20.251.252/30  172.20.251.253  1    U------um--f- MLAG-ISC   0d:2h:3m:4s

OSPF Database on EOS:

Col-BSD(su)->router#show ip ospf database
OSPF Router with ID(172.20.192.254)
           Displaying Router Link States(Area 172.20.192.254)
 LinkID           ADV Router       Age       Seq#             Checksum
172.20.192.254    172.20.192.254   117       0x80000009       0x37bb
172.20.207.62     172.20.207.62    826       0x80000005       0xc0e8
           Displaying Net Link States(Area 172.20.192.254)
 LinkID           ADV Router       Age       Seq#             Checksum
172.20.248.1      172.20.192.254   827       0x80000003       0x8c46
           Displaying Ipnet Sum Link States(Area 172.20.192.254)
 LinkID           ADV Router       Age       Seq#             Checksum
0.0.0.0           172.20.207.62    118       0x80000009       0x777

OSPF LSDB on EXOS:

Col-Core1.68 # show ospf lsdb
                Router LSAs for area 0.0.0.0
Link State ID   Adv Router      Seq#         Age Chksum  #Links
-------------------------------------------------------------
172.20.207.62   172.20.207.62   0x80000006  914  0xf1b5  5
172.20.207.126  172.20.207.126  0x8000000a  931  0x2da0  5
172.20.207.190  172.20.207.190  0x8000000c  929  0xeda0  5
172.20.207.254  172.20.207.254  0x80000009  178  0x 6b6  5
                Network LSAs for area 0.0.0.0
Link State ID   Adv Router      Seq#         Age Chksum
-------------------------------------------------------------
172.20.250.243  172.20.207.190  0x80000003  929  0xd070
                Summary LSAs for area 0.0.0.0
Link State ID   Adv Router      Seq#         Age Chksum
-------------------------------------------------------------
172.20.248.0    172.20.207.62   0x80000003  944  0x3e93
                Router LSAs for area 172.20.192.254
Link State ID   Adv Router      Seq#         Age Chksum  #Links
-------------------------------------------------------------
172.20.192.254  172.20.192.254  0x80000009  238  0x37bb  2
172.20.207.62   172.20.207.62   0x80000005  945  0xc0e8  2
                Network LSAs for area 172.20.192.254
Link State ID   Adv Router      Seq#         Age Chksum
-------------------------------------------------------------
172.20.248.1    172.20.192.254  0x80000003  948  0x8c46
                Summary LSAs for area 172.20.192.254
Link State ID   Adv Router      Seq#         Age Chksum
------------------------------------------------------------

OSPF Neighbour EXOS:

Col-Core1.69 # show ospf neighbor
Neighbor ID     Pri State              Up/Dead Time             Address         Interface
          BFD Session State
==========================================================================================
172.20.207.126    0 FULL      /DROTHER 00:01:23:02/00:00:00:02  172.20.251.242  Core1-To-
          None
172.20.207.190  120 FULL      /DR      00:01:23:00/00:00:00:10  172.20.250.243  Cores-To-
          None
172.20.192.254    1 FULL      /DR      00:01:23:00/00:00:00:00  172.20.248.1    OSPF-Col-
          None
Total number of neighbors: 3 (All neighbors in Full state)

OSPF Neighbour EOS:

Col-BSD(su)->router#show ip ospf neighbor
ID             Pri   State        Dead-Int  Address        Interface
172.20.207.62  10    Full         40        172.20.248.2   vlan2001


Col-Core1.3 # show version
Switch      : 800770-00-04 1746N-40857 Rev 4.0 IMG: 22.3.1.4
Image   : ExtremeXOS version 22.3.1.4 22.3.1.4-patch1-7 by release-manager
          on Tue Jan 16 09:05:31 EST 2018
Diagnostics : 2.5
Certified Version : EXOS Linux  3.18.48, FIPS fips-ecp-2.0.16


Col-BSD(su)->show switch
        Management   Preconfig   Plugged-in        Switch             Code
Switch    Status     Model ID    Model ID          Status            Version
------ ------------ ----------- ----------- --------------------- --------------
1      Mgmt Switch  C5G124-48P2 C5G124-48P2 OK                    06.71.03.0025
2      Stack Member C5G124-48P2 C5G124-48P2 OK                    06.71.03.0025



Many thanks in advance.
Photo of Martin Flammia

Martin Flammia

  • 6,006 Points 5k badge 2x thumb

Posted 2 months ago

  • 0
  • 1
Photo of Martin Flammia

Martin Flammia

  • 6,006 Points 5k badge 2x thumb
Figured it out.... the EOS device link-type is set to broadcast by default, whereas I had configured point-to-point on EXOS.