OSPF - Requirement

  • 0
  • 1
  • Question
  • Updated 5 years ago
Create Date: Jan 26 2012 2:52AM

Hi All, my internal LAN topology is 2 x Summit X450a-48t stacked as CORE switches and 2 x Summit x250e-48p as ACCESS switches (phones and desks).

I need to swap out my CORE X450a-48t stack for a different stack made of 4 x250e-24t switches.

I have only come across one problem, that is that the stack I am swapping does not have OSPF functionality - my knowledge of OSPF is limited but I don't know how the network will react if we replace the core switches with some without OSPF.

The 0.0.0.0 area has been set as the VLAN for my WAN but there is also a static route for same.

Can anyone make any sense of that?

Thanks

K





(from Chris_Keegan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 26 2012 3:36AM

Hello Keegster

Are you running OSPF on the LAN? If you are running it on the WAN then you should be fine. The core 450s will most likely have a static route to the WAN router. The WAN router will then advertise you routes to the other locations.

The 450a switches can be a full OSPF router with the core license which means they can be a DR or BDR of an area. The 450e can only be an edge router so they can join into an area if needed. Mathis requires adv edge license.



Does this help?



P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 26 2012 5:10AM

Hi Prusso, thanks for your reply.

I am not sure if I have OSPF running or not (it's possible someone was just toying with the idea)

If I run "sh config" I can see that the commands that were entered originally: (10.251.251.1 is my Firewall / Gateway to WAN)

configure ospf routerid 10.255.255.1
enable ospf originate-default always cost 1 type ase-type-1
enable ospf
configure ospf vlan RED priority 0
configure ospf vlan GREEN priority 0
configure ospf vlan BLUE priority 0
configure ospf add vlan WAN area 0.0.0.0
configure ospf vlan WAN priority 0
configure ospf vlan iscsi priority 0


When I run "sh ospf" on this switch I get the following: (not all of it makes sense to me).

OSPF : Enabled MPLS LSP as Next-Hop: No
RouterId : 10.255.255.1 RouterId Selection : Configured
ASBR : Yes ABR : No
ExtLSA : 8 ExtLSAChecksum : 0x47a23
OriginateNewLSA : 4955 ReceivedNewLSA : 20009
SpfHoldTime : 3 Lsa Batch Interval : 30s
CapabilityOpaqueLSA : Enabled
10M Cost : 10 100M Cost : 5
1000M Cost (1G) : 4 10000M Cost (10G) : 2
Router Alert : Disabled Import Policy File :
ASExternal LSALimit : Disabled Timeout (Count) : Disabled (7)
Originate Default : Enabled Always : Yes Type: 1 Cost: 1 Tag: 0
Redistribute:
Protocol Status cost Type Tag Policy
direct Disabled 0 0 0 None
static Disabled 0 0 0 None
rip Disabled 0 0 0 None
e-bgp Disabled 0 0 0 None
i-bgp Disabled 0 0 0 None
isis-level-1 Disabled 0 0 0 None
isis-level-2 Disabled 0 0 0 None
isis-level-1-external Disabled 0 0 0 None


On the access switch it does not even recognise the command "sh ospf" leaving me to beleive that it is not capable of supporting it.

Thanks for your help,

K











OSPF : Enabled MPLS LSP as Next-Hop: No
RouterId : 10.255.255.1 RouterId Selection : Configured
ASBR : Yes ABR : No
ExtLSA : 8 ExtLSAChecksum : 0x49c12
OriginateNewLSA : 4950 ReceivedNewLSA : 19989
SpfHoldTime : 3 Lsa Batch Interval : 30s
CapabilityOpaqueLSA : Enabled
10M Cost : 10 100M Cost : 5
1000M Cost (1G) : 4 10000M Cost (10G) : 2
Router Alert : Disabled Import Policy File :
ASExternal LSALimit : Disabled Timeout (Count) : Disabled (7)
Originate Default : Enabled Always : Yes Type: 1 Cost: 1 Tag: 0
Redistribute:
Protocol Status cost Type Tag Policy
direct Disabled 0 0 0 None
static Disabled 0 0 0 None
rip Disabled 0 0 0 None
e-bgp Disabled 0 0 0 None
i-bgp Disabled 0 0 0 None
isis-level-1 Disabled 0 0 0 None
isis-level-2 Disabled 0 0 0 None
isis-level-1-external Disabled 0 0 0 None


(from Chris_Keegan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 26 2012 5:14AM

Ignore the bottom part, I got trigger happy with the paste button ;)

K

(from Chris_Keegan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 26 2012 6:56AM

Keegster,

If I'm looking at the complete output from the OSPF portion of the config, then you have OSPF enabled, but not configured to advertise on any of your VLANs. "show ospf interface" would validate that.

The X250e and X450e come with the Edge license by default. This license level does not support any form of OSPF, just static routes and RIP. These switches can be upgraded to Advanced Edge, which will get you "OSPF-edge". This version of OSPF limits you to four advertising point-to-point OSPF interfaces and as many passive interfaces as the switch can hold in its routing table. These switches can not be upgraded to the Core level. "show license" will let you know what license you have.

"show config rtmgr" will show you the static routes you have configured.

Regards, Scott

(from Scott_Singer)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 26 2012 7:12AM

Many thanks for your help!

You are probably right, I don't think it is enabled either (see flags below).

The core switch I am on has an "Advanced Edge" licence, when I run "sh ospf interfaces" as you suggest I get the below information. The flags would indicate that it is not enabled, but what does "OFD" under 'State' for my WAN connection mean?

They are the same VLANS as the previous post, I can't be bothered to sanitise them - they don't mean much.

Thanks again.

K

VLAN IP Address AREA ID Flags Cost State Neighbors
ASA 10.251.251.2 /24 0.0.0.0 -r-f- 4/A DOWN 0
LABs 10.3.150.253 /16 0.0.0.0 -r-f- 4/A DOWN 0
DATA 10.2.150.254 /16 0.0.0.0 -r-f- 4/A DOWN 0
WAN 10.255.255.1 /24 0.0.0.0 -rif- 5/A ODR 1
iscsi 172.18.1.1 /24 0.0.0.0 -r-f- 4/A DOWN 0
SERVERS 10.1.100.254 /16 0.0.0.0 -r-f- 4/A DOWN 0
SIP 10.11.0.254 /16 0.0.0.0 -r-f- 4/A DOWN 0
TG_Clients 10.8.100.254 /24 0.0.0.0 -r-f- 4/A DOWN 0
TG_Servers 10.7.100.254 /16 0.0.0.0 -r-f- 4/A DOWN 0
TSG 10.6.1.254 /16 0.0.0.0 -r-f- 10/A DOWN 0
VOICE 10.10.0.254 /16 0.0.0.0 -r-f- 4/A DOWN 0
WIFI_LAN 10.4.150.254 /24 0.0.0.0 -r-f- 5/A DOWN 0


Flags : f - Interface Forwarding Enabled, i - Interface OSPF Enabled,
n - Multinetted VLAN, p - Passive Interface,
r - Router OSPF Enable,
A - Automatic Cost, C - Configured Cost.



(from Chris_Keegan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 26 2012 7:23AM

Sorry, I did format it al nice but it has ignored me.



See attached.



K

(from Chris_Keegan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 27 2012 3:43AM

Hey Keegster



This shows that OSPF is enabled and you have the WAN interface added to OSPF. the "ODR" means that this switch is not the DR or BDR it is "Other" essentially just and interface on the area. As Scott said even though it is on OSPF I am not sure what it is doing accept receiving routes. If you do a show IPR do you see a lot of routes in there learned from OSPF.



It doesn't look to me like you are sending out any routes as there are no other interfaces up. Most of the time you want to add the local VLAN interfaces as passive to OSPF so that you can send them out in the OSPF updates.

Since it doesn't look like you are sending out any updates you could accomplish the same thing by just settng up a default gateway in the swithc to point to your WAN router.



Does that help?



P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Jan 27 2012 7:45AM

Hi Prusso,

Sure does, thanks.

I'm going to put some static routes in and swap out tonight - should be fine. If not I will just put the old stack back as I'm not changing the config on it.

Thanks for your help,

Chris



(from Chris_Keegan)

This conversation is no longer open for comments or replies.