p2p OSPF convert to OSPF+(VRRP+MLAG)

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
Ok  we used to have a pretty simple setup 
Site 1 -> OSPF p2p -> Core
Site 2 -> OSPF p2p
Site 3 -> OSPF p2p

That way we could redistribute our customers (/30) back to our Core so that the Core would be able to send traffic to the proper site, Worked Great. 

Now our core is a MLAG of 2 switches, We spun up a VRRP on the vlan to the site betweent he mlag'd switches, set the default route on our Site switch to point at the VRRP and that works...

Put static routes for the /30's on both core switches in the mlag and customer traffic passes fine.

Now for the life of me i can't figure out what i'm doing wrong with the OSPF to get it working like it used to before, i can't use P2P because well it's 3 switches not 2. 

All i want is for the remote sites to advertise their routes to both core switches.

I tried just leaving off the link-type point-to-point and the 3 switches appeared to get stuck in 2WAY and didn't receive/advertise anything.

The config i tried

Remote site had....
create ospf                          area 1.1.1.0
configure ospf                       area 1.1.1.0 stub summary stub-default-cost 10
configure ospf                       area 1.1.1.0 authentication simple-password Passwordy
configure ospf                       area 1.1.1.0 restart-helper both
configure ospf add vlan SITE1_BACKBONE area 1.1.1.0 
configure ospf     vlan SITE1_BACKBONE neighbor add 1.1.1.1
configure ospf     vlan SITE1_BACKBONE neighbor add 1.1.1.2
configure ospf add vlan CUSTOMER1       area 1.1.1.0 link-type point-to-point passive

Core switch both had....
create ospf                              area 1.1.1.0
configure ospf                           area 1.1.1.0 stub summary stub-default-cost 10
configure ospf                           area 1.1.1.0 authentication simple-password Passwordy
configure ospf                           area 1.1.1.0 restart-helper both
configure ospf add vlan SITE1_BACKBONE     area 1.1.1.0 link-type point-to-point
configure ospf     vlan SITE1_BACKBONE neighbor add 1.1.1.3
Photo of Chris

Chris

  • 492 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of andreas

andreas

  • 1,218 Points 1k badge 2x thumb
Have you tried restarting the osof process?
Photo of Stephen Elliott

Stephen Elliott

  • 1,244 Points 1k badge 2x thumb
what licence do you have?  you'll need a core licence to enable DR/BDR negotiation.
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
As Stephen said above, in your case you will HAVE to have a core license on at least one of your XOS switches in order for the DR to be elected otherwise your will just sit in waiting mode.   
Photo of Chris

Chris

  • 492 Points 250 badge 2x thumb
ah ok, luckily i had 2 core licenses waiting to be loaded on to those 2 very core switches, because we will have more than 4 active areas :) I missed that it was required for DR election. 

So basically stick to same config, just add the core licenses onto the Core1/2 first?
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
Yes, if your just apply the license "enable license <license code>" and it will turn on, no reboot required. If you need to get your license code to the specific hardware, take the voucher # with the SN# of the switch enter them on this web page.. http://tech.extremenetworks.com/services/license-generation.aspx

Let me know if you need anything else!
Photo of Chris

Chris

  • 492 Points 250 badge 2x thumb
Ya i did that confirmed active core licenses now, and then readded the OSPF code above (minus the point-to-point) but still i'm only seeing the neighbors as 2way /DROTHER

EDIT: Nevermind, to others whoever run into this ... Make sure the priority on the core routers is set to >0 so they can be eligible to be DR/BDR :)
(Edited)
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
Sorry... did not look at the config above, you need to remove the area above as a stub and the neighbor configurations. Assuming you have area 1.1.1.0 just add the vlans. Clear your ospf on each vlan first and then add back without qualifications...

configure ospf del vlan <vlan name> 

configure ospf add vlan <vlan name> area 1.1.1.0
enable ospf

If you are still having issues get them the full config... "show config ospf"