Ping not work

  • 0
  • 2
  • Problem
  • Updated 1 year ago
  • Solved
Hello All,


I need to know the route that takes and ip address but I apply the command and it tells me Error: Invalid from address supplied, make sure it exists.

Switch.3 # ping 10.1.83.8 from 10.120.20.180 with record-route
Error: Invalid from address supplied, make sure it exists.

How should I do this correctly?

Thanks
Photo of Susana Tovar

Susana Tovar

  • 494 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 2
Photo of Brad Parker

Brad Parker, Technical Support Engineer

  • 3,500 Points 3k badge 2x thumb
The "from" address needs to be owned by the switch.
Photo of Drew C.

Drew C., Community Manager

  • 39,516 Points 20k badge 2x thumb
Don't forget that you can use traceroute from as well.
Photo of Andrew Imam

Andrew Imam, Alum

  • 1,026 Points 1k badge 2x thumb
Hi Susana,

To add to Brad's comment, if the "From" IP address is assigned to a VLAN on the switch you can check the VLAN to ensure that it has at least one active port for the switch to recognize that the VLAN interface is active. Also, you may want to include the Virtual router via which the switch is connected to the destination (e.g. VR-MGMT or VR-Default) in the "ping" command.
Please let us know if you have any questions.
Thank you.

Best regards,
Andrew
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,036 Points 20k badge 2x thumb
You'd need to tell the vr that you use - example below.

Do a "show vlan" to see the vr that the switch IP is using.

Cheers,
Ron