Port channel between Server and Extreme Summit Switch

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I need to setup a port channel between two VMware environment and extreme summit switch X460.

I have try to configure this and it break the connection on extreme but when I move back the cables to cisco everything is working fine.

I want to verify the steps that I take are correct or someone please correct me.

This is what have configured on extreme switch

 

configure vlan LAN-SERVERS add ports 1:4,1:5 untagged

enable sharing 1:4 grouping 1:4,1:5 algorithm address-based L2 lacp

 

compare  to cisco configuration 

interface Port-channel5

description ESXi01-CPT Management

switchport access vlan 106

switchport mode access

logging event trunk-status

logging event bundle-status

load-interval 30

arp timeout 10

spanning-tree link-type point-to-point

!

 

interface GigabitEthernet0/9

description ESXi01-CPT NIC05

switchport access vlan 106

switchport mode access

logging event trunk-status

logging event bundle-status

load-interval 30

keepalive 30

mls qos trust cos

channel-group 5 mode on

!

interface GigabitEthernet0/10

description ESXi01-CPT NIC05

switchport access vlan 106

switchport mode access

logging event trunk-status

logging event bundle-status

load-interval 30

keepalive 30

mls qos trust cos

channel-group 5 mode on

Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Hernandez, Joshua

Hernandez, Joshua, Employee

  • 1,564 Points 1k badge 2x thumb
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Thanks Hernandez I will try this and update the chat  if its working 

Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 13,458 Points 10k badge 2x thumb
Hi Sivuyile,

your Cisco config shows a static LAG (channel-group 5 mode on), while your EXOS config shows a dynamic LAG (enable sharing 1:4 grouping 1:4,1:5 algorithm address-based L2 lacp). A dynamic LAG requires a protocol, LACP, between the two devices. A static LAG does not use any protocol, it just groups two or more ports together into a LAG.

To configure a static LAG on EXOS, just omit the "lacp" keyword (enable sharing 1:4 grouping 1:4,1:5 algorithm address-based L2).

VMware supports LACP only with a Distributed vSwitch, while static LAGs are supported with Standard vSwitches as well.

Best regards,
Erik
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Thanks Erik , I have made my configure to the following ( enable sharing 1:4 grouping 1:4,1:5 algorithm address-based L3_L4 ) and it run super-fast no more timeout.

Thanks again guys for the rapid response. 

Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi All

 

Any please assist me I was just wandering if on extreme there is way to configure trunk vlan that allow more than 30 vlans on one trunk port.

On cisco switch configuration will look like this :

switchport trunk allowed vlan 20,100,101,103,105-109,112,120,201,203,204,206

 switchport trunk allowed vlan add 209,211,220-231,254,301

 

how can I configure the above on extreme without configure one vlan at a time.

Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,346 Points 10k badge 2x thumb
Hi,

If you are running 16.1 or above, this is done very easily by manipulating the vids instead of the vlan names.

# config vlan 20,100,101,103,105-109,112,120,201,203,204,206,209,211,220-231,254,301 add ports 1:24 tag

Regarding your first question, already answered, you wrote:

configure vlan LAN-SERVERS add ports 1:4,1:5 untagged
enable sharing 1:4 grouping 1:4,1:5 algorithm address-based L2

please note that when you create a LAG with EXOS, you'll bind the port members into a LAG, and then you'll (mostly) use only that virtual port. No need to use the other ports. Exceptions are for ACLs and things like that.

So, the best way to do the same thing, is rather:

enable sharing 1:4 grouping 1:4,1:5 algorithm address-based L2
configure vlan LAN-SERVERS add ports 1:4 untagged

The end result is the same.
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Thanks Grosjean , I will do my configuration on Monday and update this chat with finds.