Problem connecting to WiFi with mac authentication

  • 0
  • 1
  • Problem
  • Updated 9 months ago
  • Not a Problem
  • (Edited)
I have controller C35 with with AP's 3705I and 3825i, diferents SSID ́s (Internal Portal, Mac Authentication, Etc) with version 10.31.05.0003,
 But now when the clients had been conected for mac authentication after a while the clients have been disconected  and when they try connect for mac authentication this not works, if see the network options on device do not get an IP, but if you try to connect to internal portal or another ssid it works, and then they trying connect to ssid with mac authentication it works.
Photo of Salvador Gallo

Salvador Gallo

  • 452 Points 250 badge 2x thumb

Posted 10 months ago

  • 0
  • 1
Photo of Nathiya Munuswamy

Nathiya Munuswamy, Employee

  • 1,706 Points 1k badge 2x thumb
Hi Salvador Gallo,

Are you seeing this issue after code upgrade to 10.31.05.0003? Was it working fine before?
Are you using external radius server for MAC authentication?
At the time of issue, which role the clients falling into (Pre or post auth role)?
Are you seeing MAC authentication failure messages on controller or the radius server logs? 




Regards,
Nathiya M
Photo of Salvador Gallo

Salvador Gallo

  • 452 Points 250 badge 2x thumb
Hi Nathiya M,

Are you seeing this issue after code upgrade to 10.31.05.0003? Was it working fine before?
NO, i have this problem with version 10.31.03.0012, but it was not very noticeable this problem, but now i have a lot of problems

Are you using external radius server for MAC authentication?
Yes, i using an external radius and i have problem in all profiles.

At the time of issue, which role the clients falling into (Pre or post auth role)?
In this case if the user arrive to area ant try connect to ssid with mac authentication it works correctly, but after a while the user loses connection, and try to conect at the same ssid it is not possible,

Are you seeing MAC authentication failure messages on controller or the radius server logs? 
and only see logs of user that no are in data base of radius.

Regards,
Salvador
Photo of Jacob, Praveen

Jacob, Praveen, Employee

  • 1,022 Points 1k badge 2x thumb
I would suggest you open a case with GTAC to troubleshoot this issue. 
Photo of Matthew Hum

Matthew Hum

  • 362 Points 250 badge 2x thumb
Not a great solution, more of a workaround, but have you tried setting the Session-Timeout attribute in your RADIUS server? this will have the clients reauthenticate and re-establish their session before any lockup occurs. 
Photo of Bin

Bin, Employee

  • 5,350 Points 5k badge 2x thumb
Hello Salvador Gallo,

Kindly request to read the following article to troubleshoot this issue.

How to troubleshoot a client (MU) that fails to get an IP address or has an APIPA IP address (169.254.0.0/16)
 https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-troubleshoot-a-client-MU-that-fails...

Best regards,
Bin