Problem with stack between X250 - X440

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Hello people,
I have two switches in stack.
The switches are X250e-24t and X440-48p.
The version is 15.3.2.11.
This stack has two ports in trunk configured in sharing to the switch core.
The spanning tree is not configured in this network.
One week ago I had a problem because there were a l2 loop.
I think it was a stack problem, causing the misconfiguration of the two ports in sharing and lease two trunk actived.
What do you think?
Are there problems if I do a stack with two platform different?
If I upgrade the version, Can I resolve this problem?
Thank you.
Photo of Leonardo Falconi

Leonardo Falconi

  • 182 Points 100 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,524 Points 5k badge 2x thumb
Leonardo,

If upgrade is an easy option then i would suggest an upgrade to recommended version of EXOS.

Being said this, multiple factors can bring dual master in a stack and if the last one happened due to a code issue then upgrade might fix but not 100%

since X250e is the older version of hardware the recommendation is EXOS 15.3.5.2-patch1-10.

Here is a link for reference

http://www.extremenetworks.com/extrem...

If the same issue happens after upgrade then i would suggest to open up a GTAC case to analyze this further.
Photo of Vellachery, Sumeesh

Vellachery, Sumeesh, Employee

  • 3,268 Points 3k badge 2x thumb
Leonardo,

Adding to my colleagues suggestion (Karthik). Also, look for the stacking port Rx errors & Tx errors are getting incremented:-
  • show ports stack-ports rxerrors no-refresh
  • show ports stack-ports txerrors no-refresh



In case, if the Rx errors are getting incremented. Check stacking cables for good connections, firmly connected with the screws tightened.
If you have a spare stacking cable. Try swapping them with the spare one and monitor the stacking ports Rxerrors
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 45,306 Points 20k badge 2x thumb
could you share the output of "show stacking"
Photo of Drew C.

Drew C., Community Manager

  • 37,366 Points 20k badge 2x thumb
Hi Leonardo,
Were you able to resolve this issue, or do you still need assistance?
Photo of Leonardo Falconi

Leonardo Falconi

  • 182 Points 100 badge 2x thumb
Hi Drew,
I have upgraded the version and until now the problem is not appeared.
Thank you.
(Edited)