Purview appliance installation

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hi,

I got a new purview appliance. I am trying to install the software from the USB flash that shipped with it.

But I got this error " No root file system is defined" " Please correct this from the partitioning menu"

Is there any advice to solve this issue and resuming the installation?

Thanks in advance,
Husam
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Matthew Hum

Matthew Hum, Principal Engineer, APAC

  • 1,542 Points 1k badge 2x thumb
It sounds like there might be a partition problem on the USB stick.

You can re-download the appliance image from extranet.extremenetworks.com and then unzip that to a directory. Open up command prompt and type make_disk.bat (drive letter of the USB stick).
So if my USB drive was e: I would type:
make_disk.bat e:

that will reimage the USB disk and you can try reinstalling from that. On newer versions of windows you may need to open command prompt as an administrator to be able to access the MBR of the USB stick.
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb
Hi,

I tried this procedure using same flash USB. I downloaded new purview software and made this disk. But I had same problem.

I will try using different USB flash

Thanks,
Husam 
Photo of Matthew Hum

Matthew Hum, Principal Engineer, APAC

  • 1,542 Points 1k badge 2x thumb
When you try to boot from the disk does it let you do anything or say anything? or is that the first thing you see?

It could be that the appliance is not booting off the USB stick. do you see it in the BIOS? can you ensure that it boots?
(Edited)
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb
Hi,

I tried using different USB flash but I got same error.

I think the appliance is booting off the USB disk, because in case there is no USB flash I see the BIOS. But after inserting the flash disk I see an interface with three options, one of them install the software and another to check the disk. I tried to check the disk and attached error came up

Thanks,
Husam

.

Thank you for your help.
Photo of Matthew Hum

Matthew Hum, Principal Engineer, APAC

  • 1,542 Points 1k badge 2x thumb
It looks like you have a bad installer that made the bootable USB. can you re-extract the zip and try building the USB boot stick off of the new extracted folder?
can you try downloading an older appliance image and try with that? then upgrade purview using the upgrade binary?
(Edited)
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,498 Points 5k badge 2x thumb
Have you just tried to install purview on the main hard drive of the appliance? I think you are running simply checking the USB drive, not the hard drive.
Let us know if there is a problem moving forward past that.
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb
It is pv appliance from Extremenetwork
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,498 Points 5k badge 2x thumb
It did not have Purview image already installed?
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb
it seems there is no installed image because it boot off BOIS!!!
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,498 Points 5k badge 2x thumb
I discussed this with one of my peers. Our assumption based off the data presented that this is most likely a hardware problem with the hard drive controller or the hard drive itself, and that you should arrange to have an RMA done on the unit to resolve the issue.
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb
Thank you very much I will submit an RMA