Purview upgrade issues: 7.1.1.4 >> 8.1.2.59

  • 0
  • 1
  • Problem
  • Updated 2 weeks ago
  • Solved
Hello, team,

I've tried to update Purview from 7.1.1.4 to 8.1.2.59 and failed. Systems said:

root@Purview.spbgasu.ru:~$ ./purview_appliance_upgrade_to_8.1.2.59.bin
ERROR: Factory MD5 checksum: bfedbd91cb9ae8a1a3f027880158dcd0 does *not* match run time MD5 checksum: 1c7940bd1a4b0b51054e36d9de620180
This upgrade script appears to be corrupt because the internal zip file does not match
match the MD5 checksum from the factory. Please re-download the upgrade binary and try again.
./purview_appliance_upgrade_to_8.1.2.59.bin: line 685: ${LOG_FILE}: ambiguous redirect
root@Purview.spbgasu.ru:~$

What is wrong?

Thanks.
Photo of Ilya Semenov

Ilya Semenov

  • 4,408 Points 4k badge 2x thumb

Posted 2 weeks ago

  • 0
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 45,286 Points 20k badge 2x thumb
This upgrade script appears to be corrupt because the internal zip file does not match match the MD5 checksum from the factory. 
The file was corrupted either during download from the webpage or upload to the VM.
Redownload the file and try again.
Photo of Ilya Semenov

Ilya Semenov

  • 4,408 Points 4k badge 2x thumb
Ron, do you really believe that?

May be direct upgrade is not possible? I will redownload the file, OK...
Photo of Ilya Semenov

Ilya Semenov

  • 4,408 Points 4k badge 2x thumb
I've used "binary" command in ftp before downloading for all three files and it's OK now. Thanks!
Photo of Ilya Semenov

Ilya Semenov

  • 4,408 Points 4k badge 2x thumb
But I've got the following error during 8.0 >> 8.1 upgrade:

root@Purview.spbgasu.ru:~$ ./purview_appliance_upgrade_to_8.1.2.59.bin
-bash: ./purview_appliance_upgrade_to_8.1.2.59.bin: /bin/bash^M: bad interpreter: No such file or directory
root@Purview.spbgasu.ru:~$

Any ideas?
Photo of Ilya Semenov

Ilya Semenov

  • 4,408 Points 4k badge 2x thumb
But it doesn't. I am in /root. Two previous upgrades 7.1.1.9 >> 7.1.4.2 >> 8.0.5.18 worked correct. What is wrong?
Photo of SH

SH

  • 2,396 Points 2k badge 2x thumb
You can open the .bin with vi. Maybe there is an error in the script.
Seems there is a ^M after the "/bin/bash" in the first line of the script.

^M can be the dos endof line.

Please check.
Photo of Ilya Semenov

Ilya Semenov

  • 4,408 Points 4k badge 2x thumb
Checksum will not match If I change something inside *.bin. Install will fail.
Photo of SH

SH

  • 2,396 Points 2k badge 2x thumb
Yes that's right. But you can check if there is the problem (I guess) first.
Photo of SH

SH

  • 2,396 Points 2k badge 2x thumb
Here is my update file:

root@purview.sh.loc:~$ vi purview_appliance_upgrade_to_8.1.2.59.bin
#!/bin/bash
# UPDATE_HEADER_START:Version=8.1.2.59:Arch=x86_64:DeviceTypeName=NSAPPID:UPDATE_HEADER_END
#   ** NOTE: Do not change the header above.  Its needed by InventoryManager.
#
# PurviewSoftwareUpdate.sh
# This script is meant for upgrading just the Purview software.
#
#


##################################################################
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 45,286 Points 20k badge 2x thumb
I've compared the file size from the screenshot you've posted with my files on my PC and while the 7.1.4.1 & 8.0.5.18 are the same the 8.1.2.59 isn't.

The file size for 8.1.2.59 is 954,448,965 bytes...


Could you check the file size on your PC and if it's not the same reload it from the website and then upload it to Analytics.
Photo of SH

SH

  • 2,396 Points 2k badge 2x thumb
Hello Ron,

yes that's true. My filesize is like yours. Ilyas is bigger and this underlines my guess. There is a dos2unix problem and there are ^M after every line like I guess.

I downloaded a fresh file from the extreme portal via and the update starts:

root@purview.sh.loc:~$ ./purview_appliance_upgrade_to_8.1.2.59.bin
Upgrading Application Analytics Engine from 8.1.2.59 to 8.1.2.59
Already at version 8.1.2.59