Best practice configuring LACP on SecureStack C5, dedicated to Synology Bonding

  • 1
  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
Hi!

Can anybody advice me, best practice for parameters settings for LACP dedicated to create bond interfaces on Synology NAS and Windows 2012 LACP?

I have strange behaviour.
Synology connected to C5 using 4 GbE links - configured lacp
Windows 2012 also 4 GbE links - also LACP with loadbalacing mode Dynamic
MTU9000. Windows has mapped iSCSI LUN.

I'm trying copy 100GB file to Synology - transfer is 120-130MB/s, after adding next copy process, both has 120-130MB/s throughput. Adding 3rd copy, all three transfers are degraded to 5-15MB/s. Canceling 1 of them doesn't change anything. 2 copy process are working with 5-15MB/s throughput. canceling one more, returning speed of first copy process to 120-130MB/s.

I don't know where should i look for a misconfiguration or problem.
Photo of Bartosz Wolnik

Bartosz Wolnik

  • 72 Points

Posted 3 years ago

  • 1
  • 1
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,616 Points 20k badge 2x thumb
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,616 Points 20k badge 2x thumb
Hello Bartosz, 

Did this information help? 
Photo of Straw, Glyn

Straw, Glyn, Employee

  • 2,152 Points 2k badge 2x thumb
Hi Bartosz, 

I would check the port counters and see which port is incrementing the counters. It may be that all the traffic is being hashed to the same link. 

Please see the following article which describes the hashing algorithm for the securestack products 

https://gtacknowledge.extremenetworks.com/articles/Q_A/What-is-the-traffic-Distribution-Algorithm-fo...

Best Regards
Glyn