Re-direct Guest users to a website after accepting Terms and Condititons ?

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • Answered
How do you set up a process whereby wireless Guest users are re-directed to a url e.g www.extremenetworks.com after accepting terms and conditions on the captive portal ?
Photo of Siobhan Stynes

Siobhan Stynes

  • 110 Points 100 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of Christopher Frazee

Christopher Frazee, Employee

  • 1,518 Points 1k badge 2x thumb
Hello Siobhan,
      You did not detail what WiNG 5 device, but if using a wireless controller (e.g. NX, VX, RFS) or access point that supports this feature, you will use the following via the CLI:

enable [enter]

config [enter]

captive-portal xxxxxx [enter] (x represent captive portal policy. You can use tab key to auto-fill the name. If typing, capitalization matters with names)

webpage-location advanced [enter]

webpage external welcome xxxxxxxx [enter] (x represents complete URL)

webpage internal welcome use-external-success-url [enter]

com wr [enter]
Photo of Siobhan Stynes

Siobhan Stynes

  • 110 Points 100 badge 2x thumb
Thanks Christopher.  We are using a AP7522 in VC mode. Entering the CLI commands you suggested , we get a 404 error 
Photo of Michael (Misha) Elin

Michael (Misha) Elin, Employee

  • 262 Points 250 badge 2x thumb
captive portal hotspot
 webpage external welcome http://in.the.middle
 webpage internal welcome use-external-success-url
Photo of Siobhan Stynes

Siobhan Stynes

  • 110 Points 100 badge 2x thumb
Thank you
Photo of Siobhan Stynes

Siobhan Stynes

  • 110 Points 100 badge 2x thumb
That works for laptops and PC's but the the re-direct does not work on mobile devices?  Any ideas why ? 
Photo of Andrew Blomley

Andrew Blomley, Employee

  • 482 Points 250 badge 2x thumb
in the captive portal select Redirect the user to externally-hosted success URL 

 

select externally hosted 



add the URL 
Photo of Siobhan Stynes

Siobhan Stynes

  • 110 Points 100 badge 2x thumb
Thanks Andy, we have been doing this however there is no option to select ok ...its greyed out ??
We thought we were missing a previous step.
Photo of Darrel Rhodes

Darrel Rhodes, Employee

  • 1,116 Points 1k badge 2x thumb
Hi Siobhan, I believe you need an entry in all of the the URL fields before the OK button becomes available.