Remote site AP3610 and AP3630 firmware update problem

  • 0
  • 2
  • Problem
  • Updated 4 years ago
  • Solved
Hi there, hoping someone can assist me,

I'm having firmware update issues at a remote location deployed with 4 APs. 2 X 3610 and 2 X 3630 units. None of these units can update to the firmware available to them on our V2110 controller. APs (3610 and 3630 units) at the site where the controller resides have updated successfully. The APs at the remote site are running firmware revision 08.32.01.0035. The firmware available on the controller is 09.12.01.0067.

I've confirmed connectivity between the local and remote sites. I can ping the remote APs and SSH to them. Once connected to the remote AP I can ping the controller IP as well. We do have firewalls at the local and remote site and I have access to them. I can confirm that tFTP is open. It is an MPLS network and there aren't really any restrictions between the two sites. With firewall logging and packet tracing i can see tftp requests and responses at both sites.

I have reviewed some other posts on this site and can confirm that only esa0 is enabled and a default route exists on the controller. I have also tried changing the MTU size on one of the APs but this hasn't had any effect. I have also tried to change the firmware update policy on the controller from 'automated' to 'controlled upgrade' under AP -> Global Settings -> Ap Maintenance and attempted to perform a firmware upgrade manually but this appears to have the same behaviour as the automated setting.

From what I can see on the firmware documentation, upgrading from firmware revisions 08.32.01.0035 to 09.12.01.0067 should be supported. I've checked the logs on the controller and am seeing numerous critical events for all the remote APs similar to the following:

Wireless AP automatic software upgrade/downgrade has failed. May be a corrupted image was selected as a default. Please select another default image. This alarm will repeat while the system is in automatic mode: Wireless AP SN [redacted]; failed image 09.12.01.0067.

On the AP, I have tailed the /tmp/log/ap.log file and am seeing the following messages (among others)

Jan  1 00:02:32 cfgblk_rdwr.c[975]: cfgblk_rdVar: var not found [ART_RUN]Jan  1 00:03:17 cap: tftp: timeout
Jan  1 00:03:26 cap: tftp: timeout
Jan  1 00:03:43 cap: tftp: timeout
Jan  1 00:03:50 cap: tftp: timeout
Jan  1 00:03:57 cap: tftp: timeout
Jan  1 00:04:04 cap: tftp: timeout
Jan  1 00:04:26 cap: tftp: timeout
Jan  1 00:04:37 cap: tftp: timeout
Jan  1 00:04:48 cap: tftp: timeout
Jan  1 00:04:55 cap: tftp: timeout
Jan  1 00:05:14 cap: tftp: timeout
Jan  1 00:05:19 cap: tftp: timeout
Jan  1 00:05:24 cap: tftp: timeout
Jan  1 00:05:35 cap: 00214:ru_mgmt.c:2300-whsl_trans()-Discovery timeout. Reset WHSL

I see the AP does have a tftp command. I tried to manually download the firmware file from the controller using the following command:

tftp -r AC-MV-09.12.01.0067-1.bge -g [redacted]

but receive the following error:

tftp: bind: Address already in use

Am running out of ideas on how to proceed at this point.  Can anyone please help me / possibly point me in a new direction :-), 

Thank you...
Photo of ECOMMERCE\kidjo

ECOMMERCE\kidjo

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 0
  • 2
Photo of ECOMMERCE\kidjo

ECOMMERCE\kidjo

  • 90 Points 75 badge 2x thumb
Managed to resolve this, it turned out to be NAT on the remote site. Disabled NAT to the head office IP ranges and the remote APs started updating successfully