RFS6000 - cfgd process 66%, total CPU load 92%+

  • 1
  • 1
  • Problem
  • Updated 10 months ago
  • Solved
Hey,
We are currently running an RFS6000 5.8.3.6.
It has been noted that there has been degraded performance of AP's losing heartbeat on our network. I believe the 6000 is licenced for 256 AP's give or take.

When digging around, the cfgd process sits at 60%+ most of the day, and the total CPU usage sits at around 92%+ all day.

I have read that on WM3000's that cdp can cause this if the switches connected to AP's are not running cdp, causing broadcasts out of all ports, eventually reaching the 3000 and causing high CPU.

Anybody else had this issue? I wouldn't think it should be running at this rate all day..

AP71XX, AP7562's, total of around 130.
Photo of Chris

Chris

  • 160 Points 100 badge 2x thumb
  • confident

Posted 10 months ago

  • 1
  • 1
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
I can tell you one thing, the CPU utilization is way too high. Are you running the CDP? Also, what CDP are you referencing ?Cabletron discovery protocol or cisco discovery protocol ?
Photo of Chris

Chris

  • 160 Points 100 badge 2x thumb
Cisco Discovery Protocol.
Apologies.. Didn't know Cabletron dp existed.. :P

In the config on the RFS there is no 'no cdp run' command present.

Though on another RFS, an RFS7000, it isnt present either, but the cfgd process is sitting at around 2.5%.
Photo of Gary Hartstone

Gary Hartstone

  • 316 Points 250 badge 2x thumb
Here's the notes about CDP/LLDP in the Best Practice Guide

CDP / LLDP
By default, each WiNG device runs CDP and LLDP protocols, which are designed to help mitigate some of the issues with the wired infrastructure or help negotiate PoE power allocation. However, it has been identified that in rare cases when customers have mixed switching infrastructure with a mix of managed and unmanaged switches OR switches that understand both CDP and LLDP and switches that understand LLDP only - having CDP enabled might cause increased CPU load on the adopting controller. In such cases it is highly recommended to disable both CDP and LLDP on all AP profiles. You should also disable CDP even if you run managed switches that might not understand CDP protocol, such as for example Extreme or HP switches.
Photo of Chris

Chris

  • 160 Points 100 badge 2x thumb
From what i understand on all our AP's, we have put the lines "no cdp receive / no cdp transmit" on our ge1 interfaces (backlinks), which i would assume would work the same as "no cdp run" globally? Correct me if i am wrong.
Photo of Gary Hartstone

Gary Hartstone

  • 316 Points 250 badge 2x thumb
Not sure about that. The problem might be LLDP.

The guide says to disable both in the AP Profile if you're having issues.

no cdp run
no lldp run
Photo of Chris

Chris

  • 160 Points 100 badge 2x thumb
Roger. There definately isnt any 'no lldp ?" line present on the config  for the AP or RFS. Perhaps this is something to try out.
(Edited)
Photo of Chris

Chris

  • 160 Points 100 badge 2x thumb
Resolved: Turned out there was a script running that scraped the RFS for information on AP's was causing it. Perhaps because the poll time was set to 6 seconds is the real reason.. BUT each to their own.. CPU down to 11% now with cfgd @ 8% when that scrape was disabled.
(Edited)
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
Great!!!