Routing the Management address over an LACP lag

  • 0
  • 2
  • Problem
  • Updated 4 months ago
  • Solved
I am banging my head against the table trying to get my management IP routing across a LACP lag from my 220  a Dell F10 switch. 
In my early troubelshooting, I was just trying to get pinging working, which it still is not over a LAG. I was able to get it working by just 'tagging' the traffic over a regular fiber port. 
I've looked at many different articles on GTAC, and other stuff on the interwebs. 
If I plug in a laptop configured for the network of the management address, I can access the web portal. 

Here is my latest attempt. 


!Current Configuration:
!
!System Description "Extreme 220-Series 12GE, 2 10GbE SFP+ ports, 1 Fixed AC PSU, L3 Switching, 1.2.3.5, Linux 3.6.5, U-Boot 2012.10-00003-g56c397c (Mar 28 2017 - 15:11:08)"
!System Software Version "1.2.3.5"
!System Up Time          "0 days 1 hrs 32 mins 50 secs"
!Additional Packages     FASTPATH QOS,FASTPATH IPv6 Management,FASTPATH Stacking,FASTPATH Routing
!Current SNTP Synchronized Time: SNTP Client Mode Is Disabled
!
network protocol none
network parms 172.16.100.2 255.255.0.0 172.16.100.1
serviceport protocol none
serviceport ip 10.20.0.2 255.255.255.0 0.0.0.0
vlan database
vlan 2,90
vlan routing 2 1
vlan routing 90 2
exit

network mgmt_vlan 2
ip ssh server enable
no ip telnet server enable
configure
stack
member 1 1
exit
slot 1/0 1
set slot power 1/0
no set slot disable 1/0
ip routing
line console
exit

line telnet
exit

line ssh
exit

interface 1/0/13
addport 0/3/1
exit
interface 1/0/14
addport 0/3/1
exit
!

interface 1/0/5
vlan pvid 2
vlan participation include 2
exit



interface lag 1
no port-channel static
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan 2,90
exit



interface vlan 2
routing
exit



interface vlan 90
routing
ip address 172.17.90.4 255.255.255.0
exit


router rip
exit
exit


Photo of Biggtimber

Biggtimber

  • 156 Points 100 badge 2x thumb

Posted 4 months ago

  • 0
  • 2
Photo of Steve Geisser

Steve Geisser, Employee

  • 362 Points 250 badge 2x thumb
Hello Biggtimber,

I'm not 100% clear on the details of your setup, but the management interface does not do any routing.  It can be thought of more like a client in VLAN 2 with a default gateway.  In your setup, VLAN 90 is a routed interface.  I believe what you'd need to do to get this switch to route like you want, you'd have to remove the address from "network parms" and instead configure that address under "interface vlan 2", this will allow forwarding between VLAN 2 and VLAN 90, which, I think, is what you're looking for.  You would then just need to configure a default route, of course.

If you require more assistance to get this working as designed, feel free to call into the GTAC (800-872-8440) and an experienced tech can walk you through it.

Best Regards,

Steve Geisser
Escalation Support Engineer
Extreme GTAC