RSTP between Extreme and Cisco

  • 0
  • 2
  • Question
  • Updated 4 years ago
Hello,

Apologies for the the many posts. I'm relatively new to extreme.. Would just want to ask/seek help or sample configurations for anyone who has done RSTP config between Extreme and Cisco switches. Topology would be:

A----B
|        |
C----D

A&B are Extreme, C&D are Cisco. All are tagged/trunk ports.


thank you,
James
Photo of James Red

James Red

  • 322 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 2
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb


M6:U38

 

#

# Module vlan configuration.

#

configure vlan default delete ports all

configure vr VR-Default delete ports 1-50

configure vr VR-Default add ports 1-50

create vlan "data"

configure vlan data tag 20

create vlan "test"

configure vlan test tag 10

create vlan "unatagg"

configure vlan unatagg tag 50

configure ports 49 auto off speed 10000 duplex full

configure ports 50 auto off speed 10000 duplex full

configure vlan data add ports 1-2 tagged

configure vlan Default add ports 1-50 untagged

configure vlan test add ports 1-2 tagged

configure vr VR-Default delete protocol mpls

 

 

#

# Module stp configuration.

#

configure mstp region 0004968255cf

configure stpd s0 delete vlan default ports all

disable stpd s0 auto-bind vlan default

create stpd s1

create stpd s2

enable stpd s0 auto-bind vlan Default

configure stpd s0 add vlan Default ports 1 pvst-plus

configure stpd s1 add vlan test ports 1 emistp

configure stpd s2 add vlan data ports 1 emistp

configure stpd s0 add vlan Default ports 2 dot1d

configure stpd s1 add vlan test ports 2 pvst-plus

configure stpd s2 add vlan data ports 2 pvst-plus

configure stpd s0 tag 1

configure stpd s1 tag 10

enable stpd s1

configure stpd s2 tag 20

enable stpd s2

 

M7:U37

 

#

# Module vlan configuration.

#

configure vlan default delete ports all

configure vr VR-Default delete ports 1-12

configure vr VR-Default add ports 1-12

create vlan "data"

configure vlan data tag 20

create vlan "test"

configure vlan test tag 10

configure vlan data add ports 1-2 tagged

configure vlan Default add ports 1-12 untagged

configure vlan test add ports 1-2 tagged

configure vr VR-Default delete protocol mpls

 

#

# Module stp configuration.

#

configure mstp region 000496839c40

configure stpd s0 delete vlan default ports all

disable stpd s0 auto-bind vlan default

create stpd s1

create stpd s2

configure stpd s2 priority 1

enable stpd s0 auto-bind vlan Default

configure stpd s1 add vlan test ports 1 emistp

configure stpd s2 add vlan data ports 1 emistp

configure stpd s1 add vlan test ports 2 pvst-plus

configure stpd s2 add vlan data ports 2 pvst-plus

configure stpd s1 tag 10

enable stpd s1

configure stpd s2 tag 20

enable stpd s2

 

K7:U32(3550)

 

spanning-tree mode pvst

spanning-tree extend system-id

!

 

vlan 10,20-21

!

vlan 50

name UNTAGGED

!

vlan 200

 

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

 

K7:U33:

 

interface GigabitEthernet3/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

no shutdown

!

interface GigabitEthernet3/0/3

switchport trunk encapsulation dot1q

switchport mode trunk

no shutdown

!

 

spanning-tree mode pvst

spanning-tree extend system-id

!

 

vlan 10,20-21

!

 


 

Point to be consider:

 

1)      In Cisco, the Uplink to Extreme will be a trunk port. ( if not, ask him to do it) So, we need to add all the VLANs as tagged VLANs in the uplink port to Cisco.

 

2)      In Cisco, there is no need to configure the tag value for VLAN/STP domain (every instance running in Cisco for per VLAN – can be called as different STP domain). Because they create VLAN with numbers which is the tag value.

So, we need to tag the STPD domain in our switch. We will be creating 1 STPD for 1 VLAN. So, for that STPD, the tag value should be exactly same as the VLAN which is participating in that STPD domain.

3)      VLAN left is the “the native VLAN” in Cisco. By default, VLAN 1 is the native VLAN in Cisco. Check if customer is using the VLAN 1 for data purpose. If customer is not using, then just delete our VLAN “default” from the uplink port. If he is using, simply add our “Default” VLAN to any of the created STPD domain. Trust me, it will work. But, make sure you are adding the VLAN “default” to the same STPD domain in all the other switches.

 

 

Photo of James Red

James Red

  • 322 Points 250 badge 2x thumb
Thank you for the info Summit. Some clarifications:
  • if I have 4 VLANS passing through that link, do I have to create 4 stpd instances?
  • Why is it that ports 1&2 uses different types, emistp and pvst-plus?
  • If I will not use Default VLAN, can I just delete it from s0 and disable s0?
(Edited)
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Yes, 4 STPD domain.
You can configure it as PVST-plus. This doesn't make any major difference.
Photo of James Red

James Red

  • 322 Points 250 badge 2x thumb
ok, noted on that.

I more question, I noticed that in M6 you didn't configure priority for s1 and s2. In M7 you configured priority in s2 only giving it a value of 1(higher priority).
  • Does that mean that each vlan/stpd has its own priority?
  • Is it possible that in a same switch(m7), port2 for s2 is forwarding while the port2 for s1 is blocking since it has lower priority?
Photo of James Red

James Red

  • 322 Points 250 badge 2x thumb
One more thing, what if Cisco uses RSTP instead of PVST, how should the configuration on extreme side be?
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Yes. every STPD domain has it's own priority. 
You can play with priority or port cost to change the forwarding/blocking.

RSTP: Hint: Think about, how cisco works with RSTP. If there are 10 vlans configured with RSTP on Cisco then how many BPDU packet Cisco device will sent out? What is the TAG value those BPDU?

Depending upon that configure it on Extreme devices.

Please go through EXOS concept guide for further information. 
Photo of James Red

James Red

  • 322 Points 250 badge 2x thumb
Hi Sumit,

Can you give me a little more hint on the rstp config? :) Will the basic config below work when interconnecting with Cisco?

3 VLANS will pass through the link, all ports tagged

VLAN100 - Test1, ports 1:1, 1:2 tagged
VLAN101 - Test2, ports 1:1, 1:2 tagged
VLAN102 - Test3, ports 1:1, 1:2 tagged

create stpd Test
configure stpd Test mode dot1w
configure stpd Test add vlan Test1 ports 1:1,1:2
configure stpd Test add vlan Test2 ports 1:1,1:2
configure stpd Test add vlan Test3 ports 1:1,1:2
configure stpd Test ports link-type point-to-point 1:1,1:2
configure stpd Test tag 100


Thanks!
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
The above configuration may work.
The configuration is always depends on other end(Cisco) also. 
Photo of Jhonn Bejar

Jhonn Bejar

  • 320 Points 250 badge 2x thumb
I'm four months watching extreme switches, everything was fine until I got to configure spanning tree.
on cisco virtually nothing to configure spanning tree with almost everything is automated.  
but extreme it is very confusing.
If I enable pvst + must create a domain per vlan, associating ports, just watch the "show configuration stp" is long.
with that my clients are scared. They are accustomed to something practical and simple to configure.

I think that should change how extreme configure spanning tree