RSVP-TE not working

  • 0
  • 1
  • Problem
  • Updated 5 years ago
  • Solved
We did an update from 15.3.3.5-patch1-3 to 15.4.1.3-patch1-9 and RSVP become unavaible.
Before this update the RSVP was working just fine.
Below are some infomartion:

Ingress LSP Name Path Name        Destination     Next Hop I/F     UpTm Flags---------------- ---------------- --------------- ---------------- ---- --------
LSP-BKB-IIR_C    PATH-IIR_C-p4    172.27.0.10     n/a                 0 -EP--OIV


Tried to active the DEBUG and these messages appeared:

<Noti:MPLS.RSVPTE.InternalExcept> 0x00003A01-65 (0) TPM failed to expand the hops in the hop table. return code = 0X00000002


Does somebody knows what's happening?

Thank you!


Photo of julian

julian

  • 100 Points 100 badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Did you add loopback IP of transit node as strict ero in primary path ? like below,

# config mpls rsvp lsp ls1 add path "pe1pe2" primary 
Photo of julian

julian

  • 100 Points 100 badge 2x thumb
Hello Sumit,

Yes I did, see below:

configure mpls add vlan "Lo"
enable mpls vlan "Lo"
enable mpls rsvp-te vlan "Lo"
enable mpls ldp vlan "Lo"
create mpls rsvp-te path "PATH-TIO_C-BNU_C"
create mpls rsvp-te path "PATH-TIO_C-BNU_ITVC"
configure mpls rsvp-te path PATH-TIO_C-BNU_C add ero 10.200.0.13/32 strict order 100
configure mpls rsvp-te path PATH-TIO_C-BNU_ITVC add ero 10.200.0.6/32 strict order 100
create mpls rsvp-te lsp "LSP-TIO_C-BNU_C" destination 172.27.0.3
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_C" fast-reroute disable
create mpls rsvp-te lsp "LSP-TIO_C-BNU_ITVC" destination 172.27.0.2
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_ITVC" fast-reroute disable
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_C" add path "PATH-TIO_C-BNU_C" secondary
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_C" add path "PATH-TIO_C-BNU_ITVC" primary
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_ITVC" add path "PATH-TIO_C-BNU_C" secondary
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_ITVC" add path "PATH-TIO_C-BNU_ITVC" primary
configure mpls lsr-id 172.27.0.1



(Edited)
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
A transit node's loopback address cannot be added as a strict ERO without additional adjacent EROs. From one node to another, the loopback address is more than one hop away, and thus does not match the "strict" criteria. The best way to define EROs is to either create a path using the /32 nexthop IP as a strict ERO and/or use the loopback addresses as a loose ERO. 
Photo of julian

julian

  • 100 Points 100 badge 2x thumb
The strange thing is that was working well.
What the patch did to suddenly stop rsvp?

What you said is like that?


create mpls rsvp-te path "PATH-TIO_C-BNU_C"
configure mpls rsvp-te path PATH-TIO_C-BNU_C add ero 172.27.0.2/32 loose order 100
configure mpls rsvp-te path PATH-TIO_C-BNU_C add ero 172.27.0.3/32 loose order 110
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_C" add path "PATH-TIO_C-BNU_C" secondary
configure mpls rsvp-te lsp "LSP-TIO_C-BNU_C" add path "PATH-TIO_C-BNU_ITVC" primary



Photo of julian

julian

  • 100 Points 100 badge 2x thumb
After an open TAC and some troubleshooting, we did fixed by just disabling and enablis the ports who wasn't working the RSVP...
(Edited)