run diagnostics extended - not running

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Summit x450e-48P - run diagnostics extended command not doing anything but rebooting switch and returning me back to the switch login prompt.  When I run sh diagnostics, it shows that the diagnostics passed but back in November of 2012.

Any ideas?

Thanks,
Stan
Photo of Stanley Riley Jr.

Stanley Riley Jr.

  • 950 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Korsovsky, Konstantin

Korsovsky, Konstantin, Employee

  • 820 Points 500 badge 2x thumb
Hi Stan,
 symptoms looks similar for me as described in following article:
https://gtacknowledge.extremenetworks.com/articles/Solution/Diagnostics-never-ran/

Try to run diagnostics when connected via console port. It will show you more details.

Kind regards,
Konstantin
Photo of Stanley Riley Jr.

Stanley Riley Jr.

  • 950 Points 500 badge 2x thumb
Konstantin,

Thank you for your reply.  I am not even getting an error message, and I am connected via console port.

I'm guessing an RMA is in line as the resolution for this one?

Thanks,
Stan
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,594 Points 10k badge 2x thumb
While in the console what does it display? Can you paste it here?

Diagnostics is a software based command. It is possible it could be corruption in the diagnostics image or depending on the version it may not have diagnostics. Can you also past the "show version images" output as well?
Photo of Stanley Riley Jr.

Stanley Riley Jr.

  • 950 Points 500 badge 2x thumb
I will post that information tomorrow morning, the gentleman that had the switch consoled to his laptop has gone for the day. 

I can tell you that the xos version is 15.3.4.6 patch1-5.
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,594 Points 10k badge 2x thumb
Thank you Stanley,

I want to see the full file name which the "show version images" provides. This combined with the console output while attempting the diagnostics should help us figure out what is happening.

Another way to do this which might provide different results is to get into the bootrom through console and type in "boot 3". If you want to give that a whirl let us know how it goes.
Photo of Stanley Riley Jr.

Stanley Riley Jr.

  • 950 Points 500 badge 2x thumb
Patrick,

Here is the show version images results:
show version images
Card  Partition     Installation Date        Version     Name      Branch
------------------------------------------------------------------------------
Slot-1 primary   Fri Nov 14 03:49:20 UTC 2014 15.3.4.6 summitx-15.3.4.6-patch1-5.xos v1534b6-patch1-5
Slot-1 secondary Tue Jun 28 18:05:04 UTC 2011 12.5.4.5 summitX450-12.5.4.5.xos v1254b5

The switch is rebooting now, and I will try the bootrom route to see if that works.

Thanks,
Stan
Photo of Stanley Riley Jr.

Stanley Riley Jr.

  • 950 Points 500 badge 2x thumb
Here is the results of me running the command normally:
login: admin
password:

ExtremeXOS
Copyright (C) 1996-2014 Extreme Networks. All rights reserved.
Protected by US Patent Nos: 6,678,248; 6,104,700; 6,766,482; 6,618,388; 6,034,957; 6,859,438; 6,912,592; 6,954,436; 6,977,891; 6,980,550; 6,981,174; 7,003,705; 7,017,082; 7,046,665; 7,126,923; 7,142,509; 7,149,217; 7,152,124; 7,154,861; 7,245,619; 7,245,629; 7,269,135; 7,448,045; 7,447,777; 7,453,874; 7,463,628; 7,483,370; 7,499,679; 7,502,374; 7,539,750; 7,522,516; 7,546,480; 7,552,275; 7,554,978; 7,558,273; 7,568,107; 7,577,996; 7,581,024; 7,580,409; 7,580,350; 7,584,262; 7,599,292; 7,602,721; 7,606,249; 7,606,240; 7,606,263; 7,613,209; 7,619,971; 7,646,773; 7,646,770; 7,649,879; 7,657,619; 7,657,635; 7,660,259; 7,660,894; 7,668,969; 7,672,228; 7,675,915; 7,689,678; 7,693,158; 7,710,993; 7,719,968; 7,724,734; 7,724,669; 7,733,899; 7,752,338; 7,773,507; 7,783,733; 7,792,058; 7,813,348; 7,814,204; 7,817,549; 7,817,633; 7,822,038; 7,822,032; 7,821,931; 7,823,199; 7,822,033; 7,835,348; 7,843,927; 7,856,019; 7,860,006; 7,889,750; 7,889,658; 7,894,451; 7,903,666; 7,908,431; 7,912,091; 7,936,764; 7,936,687; 7,944,942; 7,983,192; 7,990,850; 8,000,344; 8,055,800; 8,059,658; 8,072,887; 8,085,779; 8,107,383; 8,117,336; 8,117,657; 8,135,007; 8,139,583; 8,159,936; 8,160,074; 8,161,270; 8,174,980; 8,204,070; 8,208,418; 8,233,474; 8,255,996; 8,274,974; 8,279,874; 8,295,188; 8,331,373; 8,369,344; 8,412,838; 8,437,359; 8,442,030; 8,464,093; 8,464,312; 8,499,093; 8,520,507; 8,560,693; 8,583,833; 8,605,726; 8,605,732; 8,659,993; 8,660,118; 8,705,532; 8,707,432; 8,724,638; 8,730,963; 8,751,647; 8,751,649.
==============================================================================

Press the <tab> or '?' key at any time for completions.
Remember to save your configuration changes.


Slot-1 CAM-ZnJ-X450STK_44.1 # run diag extended
Please specify a slot number to run diagnostics
Slot-1 CAM-ZnJ-X450STK_44.2 # run diag extended slot 1

Running Diagnostics on master may lead to new stack formation.
Are you sure you want to continue? (y/N) Yes
Sending SIGKILL to all processes
Requesting system reboot



Extreme Networks
Running Power On Self Test ...Passed








* Summit X *
Version 1.0.5.7 Branch trunk by release-manager on Mon 03/05/12
Copyright 2003-2012, Extreme Networks, Inc.
Single Processor System Initializing...


Press and hold the <spacebar> to enter the bootstrap.

Starting Default Bootloader ...




Extreme Networks






Running POST... PASSED

Version 1.0.5.7 Branch trunk by release-manager on Mon 03/05/12
Copyright 2003-2012, Extreme Networks, Inc.
Single Processor System Initializing...


Press and hold the <spacebar> to enter the bootrom.


Loading EXOS Image ...
Running Image ...

Starting ExtremeXOS 15.3.4b6
Copyright (C) 1996-2014 Extreme Networks.  All rights reserved.
Protected by US Patent Nos: 6,678,248; 6,104,700; 6,766,482; 6,618,388; 6,034,957; 6,859,438; 6,912,592; 6,954,436; 6,977,891; 6,980,550; 6,981,174; 7,003,705; 7,017,082; 7,046,665; 7,126,923; 7,142,509; 7,149,217; 7,152,124; 7,154,861; 7,245,619; 7,245,629; 7,269,135; 7,448,045; 7,447,777; 7,453,874; 7,463,628; 7,483,370; 7,499,679; 7,502,374; 7,539,750; 7,522,516; 7,546,480; 7,552,275; 7,554,978; 7,558,273; 7,568,107; 7,577,996; 7,581,024; 7,580,409; 7,580,350; 7,584,262; 7,599,292; 7,602,721; 7,606,249; 7,606,240; 7,606,263; 7,613,209; 7,619,971; 7,646,773; 7,646,770; 7,649,879; 7,657,619; 7,657,635; 7,660,259; 7,660,894; 7,668,969; 7,672,228; 7,675,915; 7,689,678; 7,693,158; 7,710,993; 7,719,968; 7,724,734; 7,724,669; 7,733,899; 7,752,338; 7,773,507; 7,783,733; 7,792,058; 7,813,348; 7,814,204; 7,817,549; 7,817,633; 7,822,038; 7,822,032; 7,821,931; 7,823,199; 7,822,033; 7,835,348; 7,843,927; 7,856,019; 7,860,006; 7,889,750; 7,889,658; 7,894,451; 7,903,666; 7,908,431; 7,912,091; 7,936,764; 7,936,687; 7,944,942; 7,983,192; 7,990,850; 8,000,344; 8,055,800; 8,059,658; 8,072,887; 8,085,779; 8,107,383; 8,117,336; 8,117,657; 8,135,007; 8,139,583; 8,159,936; 8,160,074; 8,161,270; 8,174,980; 8,204,070; 8,208,418; 8,233,474; 8,255,996; 8,274,974; 8,279,874; 8,295,188; 8,331,373; 8,369,344; 8,412,838; 8,437,359; 8,442,030; 8,464,093; 8,464,312; 8,499,093; 8,520,507; 8,560,693; 8,583,833; 8,605,726; 8,605,732; 8,659,993; 8,660,118; 8,705,532; 8,707,432; 8,724,638; 8,730,963; 8,751,647; 8,751,649.


(pending-AAA) login:
Photo of Stanley Riley Jr.

Stanley Riley Jr.

  • 950 Points 500 badge 2x thumb
After attempting to get in through the bootrom, it did load the diagnostics.  However, I'm unsure how to actually execute them from that menu.  Does each test need to be run individually from there?
Photo of Jacob, Praveen

Jacob, Praveen, Employee

  • 1,022 Points 1k badge 2x thumb
Stan,

You needn't run each individual test in the diagnostics at any point of time - the original command stays - run diag. Looking at what we are seeing here with your switch, I would most definitely think that this would need an RMA. However, please do paste the snippet of your test run here. 

Thanks,
Praveen 
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Continuing with what my colleague Praveen has to say, please attach the test run snippet to confirm further. In most likely hood it seems to be RMA though.
Photo of Jimmy Sands

Jimmy Sands

  • 432 Points 250 badge 2x thumb

What happens when after it reboots you run


show diag



Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Does it show the diag has failed the test? or something similar to that at any point?