run vm xos on vmware workstation 11

  • 0
  • 1
  • Question
  • Updated 8 months ago
  • Answered
  • (Edited)
Hi All,

I tried to set up a new virtual switch xos (xos 21.x)on vmware workstation 11 so I managed to get it installed but the network interfaces seem not te be UP although the are connected.

I know that xos vm is supported on EXSi but what about workstation ?
Is there any limitation du to the network type (E1000) ?

thank you for your help !
Photo of Sofiane ould Mohammedi

Posted 2 years ago

  • 0
  • 1
Photo of Darren Saliva

Darren Saliva

  • 662 Points 500 badge 2x thumb
I never tried to use it in vmware workstation but i have created EXOS VMs using Oracle's VirtualBox and the same thing would happen and i would have to run the script to add extra interfaces every time it happened. It happened so many times that i finally stopped using VirtualBox and installed my VMs in ESXi using vswitch to connect my VMs and I no longer have that issue. With ESXi you can also have up to 10 interfaces on a VM which helped me out for what i was doing in my lab.
Photo of Kevin Kim

Kevin Kim, Employee

  • 2,266 Points 2k badge 2x thumb
I'm running EXOS 15.7 VM with 8 x 'e1000e' interfaces added in VMware Fusion 8.0 which is equivalent to VMware Workstation for Mac. It is working fine. 
I'm quite astonished because on workstation, I'm not able to specify the e1000 network interface type.
Do you know how can we change network interface type on vmware workstation 11 ?
thank you.
Photo of Kevin Kim

Kevin Kim, Employee

  • 2,266 Points 2k badge 2x thumb
I manually edited the .vmx file to change NIC type in VMware Fusion. I think VMware Workstation would be the same. 

ethernet0.virtualDev = "e1000e"
ethernet1.virtualDev = "e1000e"
ethernet2.virtualDev = "e1000e"
ethernet3.virtualDev = "e1000e"
ethernet4.virtualDev = "e1000e"
ethernet5.virtualDev = "e1000e"
ethernet6.virtualDev = "e1000e" 
Thank you so much for the hint and indeed I've done the same modifications on vmx file actually I've had to add these lines into the file and now the ports come up...
thank you again for your help.
Photo of Edward Tsui

Edward Tsui, Employee

  • 602 Points 500 badge 2x thumb
I have tried to installed XOS VM on VMWARE workstation and the interface will never come up no matter what. I did try to edit .vmx file but still failed. Using virtualbox, on the other hand, can perfectly run the VM. I also tried to run the VM on KVM, for first time installation, it failed to mount the flashdrive. But i tried to install the VM using virtualbox and import the image to KVM, it works perfectly
Photo of M.Nees

M.Nees, Embassador

  • 8,756 Points 5k badge 2x thumb
Thanks a lot for that thread - this helps me using EXOS virtual on vm workstation.
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 12,050 Points 10k badge 2x thumb
fwiw, I have created a whole virtual lab setup on virtualbox, scripting both topologies (up to 8 interfaces per VM) and config. Works like a charm on the with the latest version of VB (5.1) and EXOS.