Sample OSPF Configuration on N-Series

  • 1
  • 1
  • Article
  • Updated 5 years ago
Article ID: 5058 

Products
Matrix N-Series
X-Pedition 

Protocols/Features
OSPF 

Goals
Sample configuration 

Solution
The following sample shows a fully formed adjacency between two ospf routers (DFE and X-Pedition) using a modified OSPF priority and cost value. 

The sample assumes the user has knowledge related to configuration of ospf fundamentals as well as vlan configuration. 

It is mandatory that the user purchase and apply an Advanced Routing license to enable this configuration feature. The "network" and "redistribute" commands will otherwise not be available (see 5025). 

The shared link between routers is on vlan 10. Following the DFE configuration is the XP configuration to which the DFE was connected.

# Router instance 3 Configuration
begin router 3

set router 3
router 3

enable
config t
license advanced <license-key>
router id 10.0.0.200
interface vlan 1
ip address 10.1.1.1 255.255.255.128
no shutdown
interface vlan 10
ip address 10.2.1.2 255.255.255.0
no ip proxy-arp
no shutdown
ip ospf cost 20
ip ospf priority 20
interface vlan 20
ip address 20.1.1.1 255.255.224.0
no shutdown
exit
router ospf 555
network 10.2.0.0 0.0.255.255 area 0.0.0.0
redistribute connected metric 300
exit
write file
exit
disable
exit
end router 3


***********************


XP8# system show active-config
Running system configuration:
!
! Last modified from Console on 2003-05-06 09:25:35
!
1 : interface create ip bb1 address-netmask 10.2.1.1/24 port et.6.1
2 : interface create ip a1 address-netmask 10.3.1.1/24 port et.6.2
!
3 : ospf create area backbone
4 : ospf add interface bb1 to-area backbone
5 : ospf add interface a1 to-area backbone
6 : ospf start
!
7: system set name XP8
XP8#
Photo of FAQ User

FAQ User, Official Rep

  • 13,620 Points 10k badge 2x thumb

Posted 5 years ago

  • 1
  • 1

There are no replies.

This conversation is no longer open for comments or replies.