saving running config on VDX 6740 logical mode

  • 0
  • 2
  • Problem
  • Updated 3 weeks ago
on VDX 6740 I cannot save the running config when the switch is in Logical Chassis mode

sw0# copy running-config startup-config
This operation is not supported in logical chassis mode.

Do I have to disable the logical chassis mode to be able to save the configuration ?
the switch is stand-alone

no vcs rbridge-id 1 logical-chassis enable

thanks


Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb

Posted 4 weeks ago

  • 0
  • 2
Photo of Mick Day

Mick Day, Employee

  • 470 Points 250 badge 2x thumb
When you switch to logical chassis mode it is no longer necessary to save running configuration

Configuration changes are automatically saved and then synchronised between all members of the chassis

The command copy running-config startup-config is no longer allowed because it is no longer necessary
Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
ok thank you. So even if I run a stand alone switch should I keep the logical chassis MODE anyway as default ?
thanks
Photo of Mick Day

Mick Day, Employee

  • 470 Points 250 badge 2x thumb
If you run a stand alone switch in logical chassis mode it will still save the running-config automatically

Also fabric cluster mode is no longer supported after NOS 7.0.x so if you were to upgrade you would need to change to logical chassis mode anyway.
Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
I am still experiencing many problems related to this.
In logical chassis mode the switch does not keep the configuration over reboots.
I applied a switch configuration copying it via scp to running config.
The configuration is OK and working.
After that I disconnected the power.
When the switch comes up again the configuration is lost.
it comes up with correct hostname but after waiting the full boot process  to be over, the host name is reset to sw0 and the configuraiton is lost.
To fix this I am forced to do:

no vcs rbridge-id 1 logical-chassis enable

apply again the configuration via scp  tftp or manually and save it

copy running-config startup config.

in this way the configuration is hold over reboots.

Any hints ?


thanks


Photo of Mick Day

Mick Day, Employee

  • 470 Points 250 badge 2x thumb
Hi Ricardo,

As mentioned in logical-chassis mode the configuration should be automatically saved, if this is not the case then there some other problem, are you able to open a case with Extreme support to investigate this?


Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
I cannot because I do not have a support contract... I just bought 6 refurbished VDX 6740 switches some of them have 6.0.1 some others 7.3.0 but anyway trying the ones with 7.3.0 they do not keep the config saved in logical chassis mode. Everything works in no logical chassis mode though
Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
I inspected the problem further. If after a configuration changes I do a reload the system comes up normally with the correct configuration saved. If the switch is turn off by detaching the power, when it comes up this happens:

Dcmd Database is corrupted. Hence, clearing the database.
2018/09/26-09:55:24, [DCM-3053], 1979, SW/0 | Active, INFO, VDX6740T-1G, Dcmd database corruption was detected. The system will startup with the default configuration for this database.

and the configuration is lost because the default config is loaded up

Photo of Mick Day

Mick Day, Employee

  • 470 Points 250 badge 2x thumb
I am a little confused, you say that everything works on no logical chassis mode, NOS 7.3.0 only supports logical chassis mode and no longer supports fabric cluster mode?

There are some options for instance netinstall, but to complete this you will need access to the NOS firmware, which you will need a support contract to access.
Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
It’s very simple. I have a bunch of vdx bought refurbished
Some of them has 6.0.2 some others 7.0.3 and other ones 7.3.0. On the 7.3.0 after detaching the power
They restart with a database error and the configuration is overwritten with the default blank config. On 7.0.3 this does not happen and on 6.0.2 on non logical chassis mode they work well. So my problem is with 7.3.0 and I wish to downgrade
Photo of Mick Day

Mick Day, Employee

  • 470 Points 250 badge 2x thumb
Ok so the problem is with the 7.3.0 and the others on lower versions of firmware work fine.

So your options are to try downgrading the 7.3.0 switch to lower than 7.1 so that you can try using it in fabric cluster mode (non logical chassis) or perform a netinstall to restore switch.

But as mentioned you will need access to NOS firmware, do you have access to Extreme portal to download the firmware?
Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
unfortunately I do not have. I bought those switches used/refurbished from a hardware reseller in California. So no support contract...
Photo of Riccardo Veraldi

Riccardo Veraldi

  • 282 Points 250 badge 2x thumb
the problem I think it is solved. I registered on the extreme support site and I am allowed to downlaod older version of network OS. In particular 7.0.2b is allowed and I Am downloading it now. This solves my problem I think. Thanks a lot for the support
Photo of Mick Day

Mick Day, Employee

  • 470 Points 250 badge 2x thumb
I have replied to the other thread