Share does not loadshare as it should

  • 0
  • 1
  • Problem
  • Updated 4 years ago
Hi
Im creating a link aggregation with LACP between a X670V and a Ericsson SSR8000. The share contains 4 10Gb links and works fine except that it doesn't loadbalance over all 4 links. We have configured it to use L3-L4 as algorithm and the destinations ipaddresses contains a fair ammount of different addresses and tcp-ports. Whatever we do it just shares over 2 ports sending out from the 670. If i disable on port that actually sends traffic then it starts using all three ports but not balanced. Anyone out there with any ideas? 
BR  Anders S
Photo of Anders Sjökvist

Anders Sjökvist

  • 160 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,676 Points 10k badge 2x thumb
Can you try using custom and crc, see if it improves the load balancing?
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
Check hashing and see if changing to CRC helps. Two options are xor or crc
Note: multicast traffic always takes same link.
Broadcast as well . Unknown unicast takes same link .
Photo of Anders Sjökvist

Anders Sjökvist

  • 160 Points 100 badge 2x thumb
Hi and thanks for your answers. 
I tried all options and i get no change still just loadsharing between 2 ports. The traffic is not multicast, only unicast with known destination.
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
If you disable the two links where you see traffic. Does it load share with other two active links .
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hey Anders is the traffic from the server using all 4 links?  When you do a show sharing are all of the ports on the switch active?

P
Photo of Anders Sjökvist

Anders Sjökvist

  • 160 Points 100 badge 2x thumb
The incomming traffic comes on all 4 links and all ports are active. If i disable 1 of the active ports the trasffic is shared among the 3 remaining ports but not even. It looks like if i have a even amount of links the sharing is done on half of them and if i have odd number of links it shares on all links but not even.
        State   Speed  % bandwidth    % bandwidth   % bandwidth   % bandwidth
================================================================================
1         R       0         0.00          2.92          0.00           49.83
2         A       10000     2.03          3.01         53.13           55.13
24        R       0         0.00          3.00          0.00           37.34
25        A       10000     2.06          4.34          0.01           55.79
================================================================================

         State   Speed  % bandwidth    % bandwidth   % bandwidth   % bandwidth
================================================================================
1         A       10000     1.48          2.92         20.33           49.83
2         A       10000     1.34          3.01         13.75           55.13
24        R       0         0.00          3.00          0.00           37.34
25        A       10000     1.38          4.34         21.04           55.79
================================================================================

         State   Speed  % bandwidth    % bandwidth   % bandwidth   % bandwidth
================================================================================
1         A       10000     1.02          2.92         27.44           49.83
2         A       10000     1.03          3.01          0.01           55.13
24        A       10000     1.07          3.00         27.95           37.34
25        A       10000     1.04          4.34          0.00           55.79
================================================================================

* sitehub79.33 # show sharing 
Load Sharing Monitor
Config    Current    Agg       Ld Share    Ld Share  Agg   Link    Link Up
Master    Master     Control   Algorithm   Group     Mbr   State   Transitions
==============================================================================
     1      1        LACP      L3_L4       1          Y      A        1
                               L3_L4       2          Y      A        1
                               L3_L4       24         Y      A        2
                               L3_L4       25         Y      A        2
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
This is an expected behaviour lag algorithm doesn't do equal load balancing on all links but instead it will only load share.
Photo of Anders Sjökvist

Anders Sjökvist

  • 160 Points 100 badge 2x thumb
Yes i know that we can't get perfect balance but i tink it shoud share among all links if you have a enough destination addresses/ports in the data flow. So i don't think it's expected behaviour.
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
Raise it to extreme TAC to get confirmation
With the results . If it is a bug they will fix it