Slow wireless speeds (5Ghz, N, 26MB??)

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I've been having intermittent issues that naturally aren't here when ever I log a case with GTAC so was wondering if anyone else has seen something similar. 

Our clients here often complain about slow wireless speeds and I'm really having a hard time tracking it down, today though I did notice that one of the clients had "full bars", connected at 5Ghz but the TX rate was only 26Mb? 

The network itself isn't anything fancy. 

Topology is Bridged locally at AP (Running a tagged VLAN)
CoS is turned off
WPA-PSK  v2 
No Authentication
WMM turned on for QoS


Anyone seen this before? 



Here is another client literally right next to this one


Photo of Tom Taylor

Tom Taylor

  • 234 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 50,124 Points 50k badge 2x thumb
Hi Tom,

I've one customer that also reports slow thruput but I wasn't onsite yet to take a closer look.

Could you tell us what AP model is used and the software version and the client type/model.
Also what type of app is used for the output in the screenshots.

The first client show a very low signal with result in "only" 10dB SNR - as you'd see on the second client the signal is far better which result in a higher MCS = rate.
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
Look at the RSSI / Noise that client is dealing with.  I bet if you were to look, there is a lot of retransmits, which further delays wireless transmissions.  What do you have your MBR set to for 5 Ghz?  Is it at least 12 Mbps?  

What I am thinking is happening is, you have some sticky clients connecting to the 5ghz radio on an AP that is much further away.  I would check the MBR settings first, and if it's at 12 Mbps and you have ok coverage,  you could start playing with probe suppression with force dissociation.  I have mine set for -75 dB (so I think the AP will boot the client at -78 dB).  
Photo of Tom Taylor

Tom Taylor

  • 234 Points 100 badge 2x thumb
Thanks for this! Although can I ask a stupid question which is where to check the MBR settings? Wifi is still a bit of a dark art to me. 

*EDIT - Found it. Thanks for this. Does quite sound like this might be the source
(Edited)
Photo of Gareth Mitchell

Gareth Mitchell, Extreme Escalation Support Engineer

  • 5,700 Points 5k badge 2x thumb
Tom

The RSSI is very low on the client with the low data rate and it is on a different channel to the client with the higher data rate.

It's hard to tell you exactly why that is, but I imagine the poor performing device is associated to a distant AP (observe the BSSID is different between the 2)

In the controller inventory report you can check which BSSID that matches or check the AP client reports to see which this AP is and map that to your wlan layout.

Typical methods to resolve this kind of sticky client problem are covered in this article: https://gtacknowledge.extremenetworks.com/articles/Solution/Issues-with-clients-staying-with-an-Access-Point-that-has-bad-signal-Sticky-Clients

-Gareth
Photo of Tom Taylor

Tom Taylor

  • 234 Points 100 badge 2x thumb
Thanks for this Gareth, agreed it does sound like this might be the issue. I've applied what's suggested and we'll see how it goes
Photo of Joshua Puusep

Joshua Puusep

  • 2,274 Points 2k badge 2x thumb
Hi Tom,

According to your snapshots, the two clients are on different radio's.  The first client has a RSSI of -83, which in my environment would not even be usable.  My initial guess would be that this is just a roaming issue.  e.g. the client's device is not connecting to the closest AP.  If you do a quick search for "roaming" on the hub, you will see quite a few posts in regards to roaming issues and how to work with them.

Some clients allow you to adjust how aggressively they roam, which is one option if the device is managed by you.  Other options include increasing the min. rate which will also reduce the cell size, or using certain features like probe suppression.

Roaming issues are a continuous battle for a lot of environments because the decision to roam is primarily up to the device.  Probe suppression could assist in micro managing roaming, however i highly recommend you consult GTAC prior implementing it because it has known bugs in various firmware versions.

If you are able to educate the users, the easiest quick fix is to have the user disable their wireless and re-enable it.  Upon re-enabling it, the adapter should re-scan for signal and choose the most optimal AP for their current location.  Obviously this is not ideal for mobile users, but it's better than signal in the -80's :-)
Photo of Tom Taylor

Tom Taylor

  • 234 Points 100 badge 2x thumb
Still seem to be having issues with this. I've had a look through the sticky client fixes and implemented it which I can now confirm clients are roaming correctly. 

I'm starting to think it's the "noise". Constantly sitting above 85 db. Is there any smart way to select what channels we're using? 

to 
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 50,124 Points 50k badge 2x thumb
The picture show that the client is connected to the 2.4GHz band but the initial problem was reported on the 5GHz band.

Please also provide AP model and software version and could you please be more precise what the issue is.... how slow is slow wireless, how to you meassure it, what is the destination, how fast does the same test work via LAN.
Photo of Tom Taylor

Tom Taylor

  • 234 Points 100 badge 2x thumb
I've just had a call with someone at Extreme, we've planned out a channel map and done several tweaks. It seems to be performing infinitely better at the moment. Thanks for the replies