SLX 9140 ip-address on layer 3 port-channel

  • 0
  • 1
  • Problem
  • Updated 1 month ago
  • Solved
Hello. I tried ro make port-channel as L3 interface but can't assign ip-address on it and have no success. Please help.
TESTWASH(config-Port-channel-30)# do sh run int e 0/1
interface Ethernet 0/1
 channel-group 30 mode active type standard
 lacp timeout long
 no shutdown
!
TESTWASH(config-Port-channel-30)#
TESTWASH(config-Port-channel-30)# do sh run int po 30
interface Port-channel 30
 no shutdown
!
TESTWASH(config-Port-channel-30)#
TESTWASH(config-Port-channel-30)# no switchport
TESTWASH(config-Port-channel-30)# ip add
                                     ^
% Invalid input detected at '^' marker.
TESTWASH(config-Port-channel-30)# ip ?
Possible completions:
  access-group   Configure IP Access group
  arp            Configure Arp Inspection
Photo of Mikhail Elchin

Mikhail Elchin

  • 92 Points 75 badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Michael Dinius

Michael Dinius, Employee

  • 230 Points 100 badge 2x thumb
Hi Mikhail,

i think you need to do it  with a Ve .

Configuring
VE route-only mode on a LAG port
Do the following to
configure
VE route-only mode on a LAG (port-channel) port.
1. Enter global
configuration
mode.
device# configure terminal
2. Create a VLAN.
device(config)# vlan 100
3. Specify a port-channel interface.
device# configure terminal
device(config)# interface port-channel 1
4. Enter the
switchport
command to
configure
Layer 2 characteristics.
device(config-Port-channel-1)# switchport
5. Specify trunk mode.
device(config-Port-channel-1)# switchport mode trunk
6. Tag the port to a VLAN.
device(config-Port-channel-1)# switchport trunk allowed vlan add 100
7. Enable tagging on native VLAN
traffic.
device(config-Port-channel-1)# switchport trunk tag native-vlan
8. Enter the
route-only
command top enable Layer 3 routing exclusively on the port.
device(config-Port-channel-1)# route-only
Use the
no route-only
command to revert to default Layer 2 and Layer 3 behavior.
9. Enable the interface and exit to global
configuration
mode.
device(config-Port-channel-1)# no shutdown
device(config-Port-channel-1)# exit
10. Verify the port-channel
configuration.
device(config-Port-channel-1)# do show running-cocnfig interface port-channel 1
interface Port-channel 1
switchport
switchport mode trunk
switchport trunk allowed vlan add 100,200
switchport trunk tag native-vlan
route-only
no shutdown
11. Enter virtual Ethernet (VE)
configuration
mode and specify the VLAN.
device(config)# interface ve 100
12. Assign an IP address and mask and enable the interface.
device(config-Ve-100)# ip address 10.2.2.2/24
device(config-Ve-100)# no shutdown
13. Verify the VE
configuration.
device(config-Ve-100)# )# do show running interface ve 100
interface Ve 100
ip proxy-arp
ip address 10.2.2.2/24
no shutdown
Photo of Mikhail Elchin

Mikhail Elchin

  • 92 Points 75 badge 2x thumb
Hello Michael Dinius,
Thank you for answer.
Unfortunately i have no such command:

interface Port-channel 30
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 10
 switchport trunk tag native-vlan
 no shutdown
!
TESTWASH(config-Port-channel-30)# r?
                                  ^
% Invalid input detected at '^' marker.
TESTWASH(config-Port-channel-30)# ?
Possible completions:
  cee                 Apply default CEE map 'default'
  describe            Display transparent command information
  description         Interface specific description
  do                  Run an operational-mode command
  exit                Exit from current mode
  help                Provide help information
  ip                  The Internet Protocol (IP).
  ipv6                The Internet Protocol version 6(IPv6).
  logical-interface   Configure a Logical Interface on port-channel
  mac                 Configure MAC parameters
  minimum-links       Least number of operationally UP links to declare port-channel UP
  mtu                 Set mtu value to interface
  no                  Negate a command or set its defaults
  priority-tag        Configure 802.1p priority tagging
  protocol            Protocol configuration
  pwd                 Display current mode path
  qos                 Quality of Service (QoS)
  service-policy      Attach Input/Output Policy Map
  shutdown            Shutdown the selected interface
  spanning-tree       Spanning tree commands
  speed               Set speed informational parameter
  switchport          Set the switching characteristics of the Layer2 interface
  system              System settings
  top                 Exit to top level and optionally run command
TESTWASH(config-Port-channel-30)#

Below is output show version, may be i have wrong firmware?

TESTWASH# show version

SLX-OS Operating System Software
SLX-OS Operating System Version: 17s.1.00
Copyright (c) 1995-2018 Brocade Communications Systems, Inc.
Firmware name:      17s.1.00a
Build Time:         02:29:08 Apr  1, 2017
Install Time:       22:39:26 Jun 23, 2017
Kernel:             2.6.34.6
Host Version:       Ubuntu 14.04 LTS
Host Kernel:        Linux 3.14.17

Control Processor:   QEMU Virtual CPU version 2.0.0

System Uptime:   0days 0hrs 15mins 48secs

Slot    Name    Primary/Secondary Versions                         Status
---------------------------------------------------------------------------
SW/0    SLX-OS  17s.1.00a                                          ACTIVE*
                17s.1.00a
Photo of Michael Dinius

Michael Dinius, Employee

  • 230 Points 100 badge 2x thumb
OK i see .
Route only is not possible on this.
So please see this example for vlan 100
vlan 100
 router-interface Ve 100

interface Ve 100
 ip address 1.1.1.1/24
no  shutdown

interface Ethernet 0/9
 channel-group 100 mode active type standard
 lacp timeout long
 no shutdown


interface Port-channel 100
 switchport
 switchport mode trunk
 switchport trunk allowed vlan add 100
 switchport trunk tag native-vlan
 shutdown
!


you can not have a ip address direct on a LACP interface only via VE and a Vlan added to the Port channel
Photo of Mikhail Elchin

Mikhail Elchin

  • 92 Points 75 badge 2x thumb
Thank you for answer. I wanted to try L3 ip-adress directly on port-channel without using VLANs, probably it is impossible on SLX 9140