SNMP contact lost after upgrade

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
We have upgraded a number of X460 stacks from release 15.3.1.4 to 16.1.1. I now have a single switch that has no SNMP contact. I am aware of an issue on the forum with previous release upgrades causing a problem, but my SNMP settings look fine.
Photo of Justsomebodi

Justsomebodi

  • 1,572 Points 1k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Taykin Izzet

Taykin Izzet , Employee

  • 3,246 Points 3k badge 2x thumb
Can you verify whether the default-group and default-user is enabled as well as the defaultUserView, defaultAdminView, and defaultNotifyView subtrees are configured. The following article will provide more information:

https://gtacknowledge.extremenetworks.com/articles/Solution/SNMP-communication-lost-after-EXOS-upgra...

You can verify the configuration using the command "show configuration snmp"
Photo of Bharathiraja, Suresh

Bharathiraja, Suresh, Employee

  • 3,536 Points 3k badge 2x thumb
Hi ,

Once after verified above article if you still have the same issue please follow below steps.

Step 1

Check the communication between switch and the netsight server

if the device is not reachable you can find below logs from netsight server

Critical    Device Down    x.x.x.x    SNMP Contact Lost: No SNMP reply from device x.x.x.x. caused by SNMP Error: Timeout[4098], last uptime was 2 Days 15:57:07.0    1    10/23/2015 08:47:57 PM    10/23/2015 08:47:57 PM    M13:U31-X450a-CE6      

Step 2

Please remove the previous SNMPv3 configuration and reconfigure as per below article

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-set-up-SNMPv3-on-EXOS

Step 3

If other switches are working fine with Netsight , please check the SNMP profile which is configured for not working switch.

If both profile are same then we have to check the credentials given for authentication (authentication and Privacy)
 
Step 4

Once after the configuration what is the SNMP status from switch -show management


SNMP stats:     InPkts 9617    OutPkts   9617    Errors 36      AuthErrors 6
                Gets   5422    GetNexts  4189    Sets   6       Drops      0   
SNMP traps:     Sent   0       AuthTraps Enabled

check the out put of show log match snmp        

Let me know if this works

Thanks,
Suresh.B
Photo of Justsomebodi

Justsomebodi

  • 1,572 Points 1k badge 2x thumb
I deleted the config and re-created it. It still fails.
Photo of Bharathiraja, Suresh

Bharathiraja, Suresh, Employee

  • 3,536 Points 3k badge 2x thumb
Hi ,

Please share the  below details,

SNMPv3 config from switch
profile config from Netsight
show log match snmp
show management

Thanks,
Suresh.B
Photo of Justsomebodi

Justsomebodi

  • 1,572 Points 1k badge 2x thumb
Hi

I will open a case for it and upload the required details.
Photo of Bharathiraja, Suresh

Bharathiraja, Suresh, Employee

  • 3,536 Points 3k badge 2x thumb
Hi,

Sure , we will help you out in GTAC case.

Thanks,
Suresh.B
Photo of Edson Yuji

Edson Yuji

  • 270 Points 250 badge 2x thumb
Hi Justsomebodi,

I also have this same problem. But it's happening in version 15.7.I'm already an open ticket in GTAC.

Let you have a question, what is your SNMP management system? CA System? Or Other?

If you want to resolve this issue quickly the suggestion is to downgrade to version 15.6.3.1 patch1-8.

Best Regards,
Edson Y.
Photo of Justsomebodi

Justsomebodi

  • 1,572 Points 1k badge 2x thumb
Hi we use Netsight. Downgrade isn't an option at the moment.
Photo of Edson Yuji

Edson Yuji

  • 270 Points 250 badge 2x thumb
I confess I did not have this problem with NetSight.

But I suspect that the SNMPMaster process does not catch, try increasing the idle-timeout time in NetSight to see if it to lose communication with the switch.

And I realized that in my case, when I do an SNMP REQUEST to the switch responds with delay SNMP RESPONSE. This time may take less than 1 second to 1 minute and 30 seconds.

But when you do the command "restart process snmpmaster, starts fast answer at first, but then responds to SNMP requests with delay.
Photo of Bharathiraja, Suresh

Bharathiraja, Suresh, Employee

  • 3,536 Points 3k badge 2x thumb
Hi Edson,

Please let me know your GTAC case number.

Thanks,
Suresh.B