SonicWall NSA to x450e to SonicPoint VLAN

  • 0
  • 1
  • Question
  • Updated 9 months ago
  • Answered
  • (Edited)
Having trouble connecting SonicPoint AP to SonicWall through VLAN. I'm not proficient in managed switches and trying my best to learn as I go. Thanks for any help on this.

Here is my setup:
SonicWall NSA setup using X2(10.11.12.1) as primary LAN with a X2:V2(10.11.13.1 using internal DHCP on SonicWall) as WLAN VLAN for SonicPoint
Windows Server 2012 R2 acting as DHCP fo X2(10.11.12.0/24)
x450e-24 to route V2 traffic from port 24 to port 1

I've setup a VLAN called wifi with tag 2 and tagged port 1 and 24 with VLAN wifi

I can't seem to get them to pass traffic. I've reset the switch several times using "unconfigure switch" to get it back to default and try again.

Does anyone know where I'm going wrong? Very new to this, most KB articles I find seem to only give the minimal info to fix a single issue and I've gotten no where for the past 3 days of trying.
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb

Posted 9 months ago

  • 0
  • 1
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb
I'm going to go ahead and blow out the config again to get my other home computers working for the moment. The kids aren't happy when I kill their netflix trying to learn new stuff :(
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,518 Points 2k badge 2x thumb
You should use vlan as untagged
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb
I've played with it some more today and need all VLAN's to go through port 24 from my SonicWall. So should I create VLAN SonicPoint Tag 2 to correspond with the VLAN I created on my SonicWall and then tag port 24 on V2 and untag it on port 1 where my SonicPoint trying to gain access to V2. Or am I going at this completely wrong and need to start reading again. Thanks in advance!
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,488 Points 2k badge 2x thumb
You understood that correcct. Go ahead and try that!
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb
So this is what I have so far and it's not allowing my VLAN 2 to pass from port 24 to port 1 and get an IP address from the pool I setup on the SonicWall, when I leave it default it pulls an IP from my servers pool. 


X450e-24p.4 # show config
#
# Module devmgr configuration.
#
configure sys-recovery-level switch reset

#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-26
configure vr VR-Default add ports 1-26
configure vlan default delete ports 1
create vlan "SonicPoint"
configure vlan SonicPoint tag 2
configure vlan Default add ports 1 tagged
configure vlan Default add ports 2-26 untagged
configure vlan SonicPoint add ports 24 tagged
configure vlan SonicPoint add ports 1 untagged
configure vlan Default ipaddress 10.11.12.201 255.255.255.0

#
# Module fdb configuration.
#

#
# Module rtmgr configuration.
#

#
# Module mcmgr configuration.
#

#
# Module aaa configuration.
#

#
# Module acl configuration.
#




#
# Module bfd configuration.
#

#
# Module cfgmgr configuration.
#

#
# Module dosprotect configuration.
#

#
# Module dot1ag configuration.
#

#
# Module eaps configuration.
#

#
# Module edp configuration.
#

#
# Module elrp configuration.
#

#
# Module ems configuration.
#

#
# Module epm configuration.
#

#
# Module erps configuration.
#

#
# Module esrp configuration.
#

#
# Module ethoam configuration.
#

#
# Module etmon configuration.
#

#
# Module hal configuration.
#

#
# Module idMgr configuration.
#

#
# Module ipSecurity configuration.
#

#
# Module ipfix configuration.
#

#
# Module lldp configuration.
#

#
# Module mrp configuration.
#

#
# Module msdp configuration.
#

#
# Module netLogin configuration.
#

#
# Module netTools configuration.
#

#
# Module poe configuration.
#

#
# Module rip configuration.
#

#
# Module ripng configuration.
#

#
# Module snmpMaster configuration.
#
disable snmp access

#
# Module stp configuration.
#
configure mstp region 00049635490b
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
enable stpd s0 auto-bind vlan Default

#
# Module telnetd configuration.
#
disable telnet

#
# Module tftpd configuration.
#

#
# Module thttpd configuration.
#
enable web http

#
# Module vmt configuration.
#

#
# Module vsm configuration.
#
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb
I just don't see it sending the tag over to the SonicWall, I can see the following error when I change port 24 to TAG under the default VLAN 1.

Malformed or unhandled IP packet dropped10.11.12.2, 53251, X210.11.12.1, 443tcpVLAN ID: 1


But a soon as I change port 24 back to untagged, I'm back online but still not passing a VL2 in the packet from my laptop hooked up to port 1.
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb
So I added a VL1 to my SonicWall just to see if the VL1 from default would reach out to connect the SonicPoint and received this in my logs.

Drop WLAN traffic from non-SonicPoint devices 10.11.12.200, 58549, X2:V1 64.233.160.188, 5228tcp

So I know my setup on the SonicWall is correct, just fighting the switch to pass the right info along.
Photo of Robert Quasdorf

Robert Quasdorf

  • 130 Points 100 badge 2x thumb
Oh well, I gave it a shot again and still cannot get port 1 to send/receive over VLAN 2 and still have other VLAN traffic to pass through 24 to get to all other ports.