STP Configuration Advice

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Good day all!  Could someone help me translate the following Cisco (2960) STP config lines into STP lines that I'd need to put on an Extreme X440 that I'm replacing the Cisco 2960 with?

spanning-tree mode pvst  
spanning-tree extend system-id
spanning-tree vlan 1 priority 28672

Currently we have two Ciscos and two HPs blade switches in this STP topology. One of the Cisco's is the root with priority of 24576. So the I'm replacing the secondary/28672 Cisco switch with the Extreme X440. The HP blade switches have a priority of 32768.

Also, in my research/reading, I read a few times (might be legacy articles) that PVST is a Cisco thing that Extreme might not be able to do. Possibly old articles I found? All VLANs in all switches are default VLAN 1.

Thanks all!

Photo of Network Engineering Team

Posted 3 years ago

  • 0
  • 1
Photo of Stephen Williams

Stephen Williams, Employee

  • 8,582 Points 5k badge 2x thumb
Are you just using the default/native vlan on the x440?  It will work but the config gets big with lots of VLANs.
Photo of Zelnosky, Kevin

Zelnosky, Kevin, Employee

  • 1,104 Points 1k badge 2x thumb

I just sent you an email with an attached document, as I have been assigned your GTAC case that you opened up earlier today.

I am going to go ahead and paste the output of the section related to STP / PVST+ in the Extreme / Cisco doc that I attached for the completeness of this HUB conversation.

Extreme Configuration (EXOS)

configure vlan test add port 3 tagged

conf vlan "Default" del port 3

create stpd domain_test

conf stpd "domain_test" add vlan "test" ports 1,3 pvst-plus

conf stpd "domain_test" tag 10

con stpd "domain_test" mode dot1d

conf stpd "domain_test" default-encapsulation pvst-plus

conf stpd "domain_test" ports link-type point-to-point 1,3

enable stpd "domain_test"

disable edp port 3


Cisco Configuration (IOS)

configure terminal

interface gigabitEthernet 0/3

no cdp enable

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

no shutdown


configure terminal

spanning-tree vlan 10

spanning-tree mode pvst

spanning-tree extend system-id


copy run start

Thanks Stephen! Yes, I'll be using the default/native VLAN on the X440. 
I replied to your TAC case Kevin. I've had great luck using the Hub and hoping to here as well.

Simply need these 3 Cisco STP lines converted to Extreme XOS ( STP lines:

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 28672

As I mentioned to Stephen, we're using the default untagged VLANs on the X440. No L3 stuff, just very simple/very basic out-of-the box config on the X440. All I've added was some SNMP stuff for monitoring and slapped on IP on the default VLAN for administration. Now just need some help with the STP lines and I'm ready to hopefully rack and use it in lieu of the Cisco 2960 (eventually replace both 2960s).

Thanks again!
Photo of Stephen Williams

Stephen Williams, Employee

  • 8,582 Points 5k badge 2x thumb
Cisco's implementation of PVST+ on the native vlan or vlan1 is still proprietary.  Extreme Networks support PVST+ on any other Cisco vlans as they follow the 802.1q standard being a trunked vlan.  If you moved the native vlan traffic to a trunked vlan it would work.  I wish I had a better answer, sorry...

Photo of Marcus Florido

Marcus Florido

  • 350 Points 250 badge 2x thumb
The GTAC support is outstanding.  Follow their advice first.  Failing that, I'd move to MSTP.  In the Cisco world, every time you create a VLAN, you create a spanning tree instance to go with it even though you may only have one physical topology.  Any implementation of PVST is inefficient at best.  On the last job I had, we were integrating a large Cisco network with a smaller multiple-vendor network.  MSTP was our answer.  Although MSTP will require more configuration (try using NetSight), the industry standard implementation of spanning tree will work with all platforms.  Good luck.

Photo of Dave Hammers

Dave Hammers, Dir SW Engineering

  • 3,362 Points 3k badge 2x thumb