STP errors

  • 0
  • 1
  • Question
  • Updated 4 years ago
The following error is filling up the logs. Port 1:45 is the uplink port to another extreme switch. I am unable to find a solution for this. Need assistance.

<Erro:STP.InBPDU.Drop> Slot-1: Port=1:45: No associated STP port for STP Domain tag 10 (Rate-limited)

I can share more details if needed.
Photo of Jeevan

Jeevan

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hello Jeevan

It looks as if the switch is receiving a STP BPDU fro the uplink port.  Is the switch that it is connected to running STP?

Thanks
P
Photo of Jeevan

Jeevan

  • 100 Points 100 badge 2x thumb
Yes, both this switch and the neighbor are running STP.
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,304 Points 10k badge 2x thumb
Hi Jeevan,

Since both of these switches are running STP, most likely there is a mismatch in the carrier vlan configured for the spanning tree domain. Is the switch on the other end seeing a similar log message?
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
Mostly happens due to mismatch in stp configuration .
easiest way is to capture the bpdu packet and see why there is a mismatch 
and then fix it.[please use TCPdump or do port mirroring]
sometimes if we receive a bpdu from 3rd party switches cisco [pvst].
its a bpdu which is not understood by extreme so we get the error.
Note : pvst+ is understood by extreme if we have the extreme switch configured for pvst+
Photo of Jeevan

Jeevan

  • 100 Points 100 badge 2x thumb
Can you point me to a doc which explains configuring extreme switch for pvst+ ?
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
Per VLAN Spanning TreeSwitching products that implement Per VLAN Spanning Tree (PVST) have been in existence for many
years and are widely deployed.
To support STP configurations that use PVST, ExtremeXOS has an operational mode called PVST+.
Note
In this document, PVST and PVST+ are used interchangeably. PVST+ is an enhanced version
of PVST that is interoperable with 802.1Q STP. The following discussions are in regard to
PVST+, if not specifically mentioned.

Extreme Exos concepts guide 15.6
Please refer page 1069
Photo of Jeevan

Jeevan

  • 100 Points 100 badge 2x thumb
I tried adding a tag for STP Domain and i get the following error:

Error: Please configure a stpd dot1q tag first

Is there an example i can follow to configure stp for a cisco extreme networks mixed environment ?
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb



M6:U38

 

#

# Module vlan configuration.

#

configure vlan default delete ports all

configure vr VR-Default delete ports 1-50

configure vr VR-Default add ports 1-50

create vlan "data"

configure vlan data tag 20

create vlan "test"

configure vlan test tag 10

create vlan "unatagg"

configure vlan unatagg tag 50

configure ports 49 auto off speed 10000 duplex full

configure ports 50 auto off speed 10000 duplex full

configure vlan data add ports 1-2 tagged

configure vlan Default add ports 1-50 untagged

configure vlan test add ports 1-2 tagged

configure vr VR-Default delete protocol mpls

 

 

#

# Module stp configuration.

#

configure mstp region 0004968255cf

configure stpd s0 delete vlan default ports all

disable stpd s0 auto-bind vlan default

create stpd s1

create stpd s2

enable stpd s0 auto-bind vlan Default

configure stpd s0 add vlan Default ports 1 pvst-plus

configure stpd s1 add vlan test ports 1 emistp

configure stpd s2 add vlan data ports 1 emistp

configure stpd s0 add vlan Default ports 2 dot1d

configure stpd s1 add vlan test ports 2 pvst-plus

configure stpd s2 add vlan data ports 2 pvst-plus

configure stpd s0 tag 1

configure stpd s1 tag 10

enable stpd s1

configure stpd s2 tag 20

enable stpd s2

 

M7:U37

 

#

# Module vlan configuration.

#

configure vlan default delete ports all

configure vr VR-Default delete ports 1-12

configure vr VR-Default add ports 1-12

create vlan "data"

configure vlan data tag 20

create vlan "test"

configure vlan test tag 10

configure vlan data add ports 1-2 tagged

configure vlan Default add ports 1-12 untagged

configure vlan test add ports 1-2 tagged

configure vr VR-Default delete protocol mpls

 

#

# Module stp configuration.

#

configure mstp region 000496839c40

configure stpd s0 delete vlan default ports all

disable stpd s0 auto-bind vlan default

create stpd s1

create stpd s2

configure stpd s2 priority 1

enable stpd s0 auto-bind vlan Default

configure stpd s1 add vlan test ports 1 emistp

configure stpd s2 add vlan data ports 1 emistp

configure stpd s1 add vlan test ports 2 pvst-plus

configure stpd s2 add vlan data ports 2 pvst-plus

configure stpd s1 tag 10

enable stpd s1

configure stpd s2 tag 20

enable stpd s2

 

K7:U32(3550)

 

spanning-tree mode pvst

spanning-tree extend system-id

!

 

vlan 10,20-21

!

vlan 50

name UNTAGGED

!

vlan 200

 

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

 

K7:U33:

 

interface GigabitEthernet3/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

no shutdown

!

interface GigabitEthernet3/0/3

switchport trunk encapsulation dot1q

switchport mode trunk

no shutdown

!

 

spanning-tree mode pvst

spanning-tree extend system-id

!

 

vlan 10,20-21

!

 

Photo of M.Nees

M.Nees, Embassador

  • 9,264 Points 5k badge 2x thumb
i see the same error when neighbour switch is a enterasys b5. It seem because enterasys RSTP / BPDU have no vlan association, X440 printed this error to all non carrier (tagged) VLANs on that interswitch link!

Does anybody know how i can avoid this messages?