Subvlan IPv6 not accessable

  • 0
  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
Hi, I have two switches connected by a grouping of 3 ports across a vlan called "Dedicated" tagged 200 on each side.

On one side is an X450 which is connected to outside networks and has BGP. The other side is an X440 which has has the "Dedicated" vlan defined as a super-vlan and has a subvlan called "subvlan1". I have got IPv4 networking working perfectly across the two switches, however IPv6 networking is not working on the subvlan's. Is there something I have to enable for this?

On the X450 side I have defined x:x::1/32, on X440 side I have x:x::2/32. Both of these networks are reachable via the internet. I have also defined the network x:x:x:x::1/64 on the X440 side which I would like to give access to a server connected to subvlan1. the x:x:x:x::1 address is pingable via the internet but the server connected to subvlan1 cannot ping x:x:x:x::1, x:x::1 or x:x::2.

It seems all IPv6 traffic is being blocked by something. Can anyone help with this? Is IPv6 allowed with subvlan's?

Setup is:

X450 - Dedicated vlan tagged 200 with IP x:x::1/32
X440 - Dedicated vlan tagged 200 with IP x:x::2/32 (is supervlan)
         - Dedicated vlan IP assigned additional address x:x:x:x::1/64 (same network as x:x::1/32 and x:x::2/32)
         - Server connected to subvlan1 (subvlan of Dedicated), has no IPv6 networking access

I have added the default route:
config iproute add default x:x::1/32

This was what solved the IPv4 networking for me, but with IPv6 it does not solve the problem.
Photo of Michael Goodliffe

Michael Goodliffe

  • 670 Points 500 badge 2x thumb

Posted 3 years ago

  • 0
  • 2

Be the first to post a reply!