Summit x460 and PIM IGMP

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have troble with multicat routing from VLAN with Multicast server to VLAN with subscribers.

( REC_VLAN - Subscribers ) - x460 - ( SEND_VLAN - Multicast server ) 

System Type:      X460-24t
Image Selected:   primary
Primary ver:      15.5.3.4 patch1-6 Enabled License Level: Core

Here my config:

configure vlan mgmt_switch_core tag 104create vlan "REC_VLAN"
configure vlan REC_VLAN tag 109
create vlan "SEND_VLAN"
configure vlan SEND_VLAN tag 2001
configure vlan REC_VLAN add ports 24 tagged
configure vlan SEND_VLAN add ports 8 untagged
configure vlan SEND_VLAN ipaddress 10.3.0.2 255.255.255.252
enable ipforwarding vlan SEND_VLAN
configure vlan REC_VLAN ipaddress 10.3.3.5 255.255.255.252
enable ipforwarding vlan REC_VLAN
enable ipmcforwarding vlan "REC_VLAN"
enable ipmcforwarding vlan "SEND_VLAN"
configure igmp snooping "REC_VLAN" ports 24 add static router
configure pim add vlan "SEND_VLAN" sparse
configure pim crp vlan "SEND_VLAN" "MCAST_TEST" 100
configure pim add vlan "REC_VLAN" sparse passive
configure pim vlan "REC_VLAN" dr-priority 100
enable pim
configure pim crp static 10.3.0.2 "MCAST_TEST" 100
MCAST_TEST:
entry m {
if match any { }
        then {
                nlri 225.1.1.0/24 ;
        }
}
On egress vlan I can see subscribers and static router: 

show igmp snooping "REC_VLAN"
Router Timeout                :    260 sec
Host Timeout                  :    260 sec
Igmp Snooping Fast Leave Time :   1000 ms
VLAN REC_VLAN         (109) Snooping=Enabled
    Port   Host            Subscribed        Age    Group-Limit
    24     10.3.3.6        225.2.1.1         60     0
    24     10.3.3.6        239.255.255.250   65     0
    24     10.3.3.5        All Groups(s)     0      0

On ingress vlan I can see server:
show igmp snooping "SEND_VLAN"Router Timeout                :    260 sec
Host Timeout                  :    260 sec
Igmp Snooping Fast Leave Time :   1000 ms
VLAN SEND_VLAN        (2001) Snooping=Enabled
    Group           Sender          Age
    225.2.1.1       10.3.0.1        0
    1 Incoming multicast streams



Multicast traffic present on ingress port:

clear counters ports all
show ports 8 statistics no-refresh
Port      Link     Tx Pkt       Tx Byte       Rx Pkt       Rx Byte Rx Pkt Rx Pkt
          State    Count        Count         Count        Count    Bcast  Mcast
================================================================================
8         A             7          531        40567     55245069        2    40565
================================================================================
          > indicates Port Display Name truncated past 8 characters
          Link State: A-Active, R-Ready, NP-Port Not Present, L-Loopback



But it doesn't present on egress port:

how ports 24 statistics no-refreshPort      Link     Tx Pkt       Tx Byte       Rx Pkt       Rx Byte Rx Pkt Rx Pkt
          State    Count        Count         Count        Count    Bcast  Mcast
================================================================================
24        A            10         1548           10         1210        4        6
================================================================================
          > indicates Port Display Name truncated past 8 characters
          Link State: A-Active, R-Ready, NP-Port Not Present, L-Loopback

What I need to do for multicast routing between REC_VLAN and SEND_VLAN.
I don't need MVR, because I have two multicast upstreems (LOCAL - SEND_VLAN) and from neighbor AS.
Photo of Lebed Sergey

Lebed Sergey

  • 102 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Jarek

Jarek

  • 2,398 Points 2k badge 2x thumb
Hi,

check TTL for multicast streams.

--
Jarek
Photo of Lebed Sergey

Lebed Sergey

  • 102 Points 100 badge 2x thumb
TTL = 32. This multicast server (in SEND_VLAN) works fine in another multihop RPT
(Edited)
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Hi Lebed,

On ingress vlan I can see server:
show igmp snooping "SEND_VLAN"Router Timeout                :    260 sec
Host Timeout                  :    260 sec
Igmp Snooping Fast Leave Time :   1000 ms
VLAN SEND_VLAN        (2001) Snooping=Enabled
    Group           Sender          Age
    225.2.1.1       10.3.0.1        0
    1 Incoming multicast streams

Multicast server is sending Multicast group IP   225.2.1.1 but in policy you mentioned nlri 225.1.1.0/24.

Please edit the MCAST_TEST and mentioned the 225.2.1.1/24.

I hope this would resolve the issue.
Photo of Lebed Sergey

Lebed Sergey

  • 102 Points 100 badge 2x thumb
After several attempts I made so stupid mistake. Thank you! 
Photo of Justin Schmidt

Justin Schmidt

  • 220 Points 100 badge 2x thumb
Just reading this thread. I was wondering why you needed a policy at all for this to work?
Photo of Lebed Sergey

Lebed Sergey

  • 102 Points 100 badge 2x thumb
because in production I have 2 multicast upstream's, with different multicast groups:

show pim rp-set
Group           Mask            C-RP            Origin    Priority  Timeout
239.13.1.0      255.255.254.0   x.x.x.254   static    100       0
225.1.1.0       255.255.255.0   10.3.0.1        static    100       0
225.50.50.0     255.255.255.0   x.x.x.254   static    100       0
234.5.2.0       255.255.255.128 x.x.x.254   static    100       0
224.2.2.0       255.255.255.224 x.x.x.254   static    100       0
239.60.8.1      255.255.255.255 x.x.x.254   static    100       0
and RP for them defined by policy
(Edited)