Switch X460G2 - eee set enable error

  • 0
  • 2
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
tHi,

I have an problem with an X460-G2-48p switch witch gives the following erors on 8 ports. The ports where working fine until a few days ago, now they dont come up annymore.

2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=7, unit=0, enable=0, rv=-162015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=6, unit=0, enable=0, rv=-16
2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=5, unit=0, enable=0, rv=-16
2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=8, unit=0, enable=0, rv=-16
2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=3, unit=0, enable=0, rv=-16
2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=2, unit=0, enable=0, rv=-16
2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=1, unit=0, enable=0, rv=-16
2015-06-24 17:21:54.73 <Erro:Kern.Card.Error> Slot-2: bcm_custom_extr_eee_config_set(16711): eee set enable error, port=4, unit=0, enable=0, rv=-16
2015-06-24 17:21:37.22 <Erro:HAL.Card.Error> Slot-1: PoE budget configuration is not allowed when dynamic budget is enabled
2015-06-24 17:21:37.22 <Erro:HAL.Card.Error> Slot-2: PoE budget configuration is not allowed when dynamic budget is enabled
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:8, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:7, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:6, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:5, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:4, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:3, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:2, rv = -16
2015-06-24 17:21:30.72 <Erro:HAL.Port.Error> Slot-1: Failed to set eee config on port 2:1, rv = -16

The switch is part of an stack with another X460-G2-48p. The other switch is still working fine. Even an diagnostics check didn't gave an answer.
I am running the 15.7.1.4 patch 2 on the stack. other than the first 8 ports of slot2 the stack is working normal
Photo of Admin ZML

Admin ZML

  • 202 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 2
Photo of Taykin Izzet

Taykin Izzet , Employee

  • 2,924 Points 2k badge 2x thumb
Could you confirm whether EEE (Energy Efficient Ethernet) is enabled on these ports? This can be done using the command 'show configuration vlan'.

Example:
X460G2-24p-G4.9 # show configuration "vlan"
# Module vlan configuration.
#
configure ports 1 eee on
configure ports 2 eee on
...

I understand that the ports are not working but please also confirm further whether it is just PoE that is not working, or whether data alone works.

I do see a similar message under CR xos0055658 though there are no reports of the ports being affected under this CR.

Disabling eee (if enabled) for the time being will help isolate the issue and allow us to troubleshoot further.
(Edited)
Photo of Admin ZML

Admin ZML

  • 202 Points 100 badge 2x thumb
I haven't got any configurations for eee. The ports are not responding (data and/or POE)
I have the following output (names and ip changed)

## Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1:1-54, 2:1-54
create vr "VR-External"
create vr "VR-Internal"
create vr "VR-Ipt"
create vr "VR-ala"
configure vlan default delete ports 1:1-54, 2:1-54
create vlan "Ext_3" vr VR-External
configure vlan Ext_3 tag 192
create vlan "Ext_4" vr VR-External
configure vlan Ext_4 tag 19
create vlan "Ext_1" vr VR-External
configure vlan Ext_1 tag 190
create vlan "Ext_2" vr VR-External
configure vlan Ext_2 tag 191
create vlan "In_5" vr VR-Internal
configure vlan In_5 tag 250
create vlan "Int_3" vr VR-Internal
configure vlan Int_3 tag 20
create vlan "Int_2" vr VR-Internal
configure vlan Int_2 tag 202
create vlan "Int_4" vr VR-Internal
configure vlan Int_4 tag 209
create vlan "Int_1" vr VR-Internal
configure vlan Int_1 tag 200
create vlan "Int_6" vr VR-Internal
configure vlan Int_6 tag 201
create vlan "Ipt_1" vr VR-Ipt
configure vlan Ipt_1 tag 22
create vlan "ala-3" vr VR-ala
configure vlan ala-3 tag 21
create vlan "ala-1" vr VR-ala
configure vlan ala-1 tag 219
create vlan "ala-2" vr VR-ala
configure vlan ala-2 tag 210
disable port 1:49
configure ports 1:49 auto off speed 10000 duplex full
disable port 1:50
configure ports 1:50 auto off speed 10000 duplex full
disable port 1:51
configure ports 1:51 auto off speed 10000 duplex full
disable port 1:52
configure ports 1:52 auto off speed 10000 duplex full
disable port 1:53
configure ports 1:53 auto off speed 10000 duplex full
disable port 1:54
configure ports 1:54 auto off speed 10000 duplex full
disable port 2:49
configure ports 2:49 auto off speed 10000 duplex full
disable port 2:50
configure ports 2:50 auto off speed 10000 duplex full
disable port 2:51
configure ports 2:51 auto off speed 10000 duplex full
disable port 2:52
configure ports 2:52 auto off speed 10000 duplex full
disable port 2:53
configure ports 2:53 auto off speed 10000 duplex full
disable port 2:54
configure ports 2:54 auto off speed 10000 duplex full
configure vlan Ext_3 add ports 1:1-2, 1:5, 1:33-34, 1:37, 1:47-48, 2:1-2, 2:5, 2:33-34, 2:37, 2:47-48 tagged
configure vlan Ext_4 add ports 1:21-24, 1:47-48, 2:21-24, 2:47-48 tagged
configure vlan Ext_4 add ports 1:15-16, 2:15-16 untagged
configure vlan Ext_1 add ports 1:1-2, 1:5, 1:33-34, 1:37, 1:47-48, 2:1-2, 2:5, 2:33-34, 2:37, 2:47-48 tagged
configure vlan Ext_2 add ports 1:1-2, 1:5, 1:33-34, 1:37, 1:47-48, 2:1-2, 2:5, 2:33-34, 2:37, 2:47-48 tagged
configure vlan In_5 add ports 1:3-4, 1:6, 1:35-36, 1:38, 1:47-48, 2:3-4, 2:35-36, 2:38, 2:47-48 tagged
configure vlan Int_3 add ports 1:3-4, 1:6, 1:35-36, 1:38, 2:3-4, 2:6, 2:35-36, 2:38 tagged
configure vlan Int_3 add ports 1:21-28, 2:21-28 untagged
configure vlan Int_2 add ports 1:7-10, 2:7-10, 2:39-40 untagged
configure vlan Int_4 add ports 1:3-4, 1:6, 1:35-36, 1:38, 1:47-48, 2:3-4, 2:6, 2:35-36, 2:38, 2:47-48 tagged
configure vlan Int_1 add ports 1:3-4, 1:6, 1:35-36, 1:38, 2:3-4, 2:6, 2:35-36, 2:38 tagged
configure vlan Int_1 add ports 1:11-14, 2:11-14 untagged
configure vlan Ipt_1 add ports 1:47-48, 2:47-48 tagged
configure vlan ala-3 add ports 1:17-20, 2:17-20 untagged
configure vlan ala-1 add ports 1:47-48, 2:47-48 tagged
configure vlan ala-2 add ports 1:3-4, 1:6, 1:35-36, 1:38, 2:3-4, 2:6, 2:35-36, 2:38 tagged
configure vlan Int_3 ipaddress a.y.10.1 255.255.255.0
enable ipforwarding vlan Int_3
configure vlan Int_2 ipaddress a.y.3.1 255.255.255.0
enable ipforwarding vlan Int_2
configure vlan Int_4 ipaddress a.x.254.4 255.255.255.248
enable ipforwarding vlan Int_4
configure vlan Int_1 ipaddress a.y.0.1 255.255.255.0
enable ipforwarding vlan Int_1
configure vlan Int_6 ipaddress a.y.2.1 255.255.255.0
enable ipforwarding vlan Int_6
configure vlan ala-3 ipaddress a.z.10.1 255.255.255.0
enable ipforwarding vlan ala-3
configure vlan ala-1 ipaddress a.x.253.4 255.255.255.248
enable ipforwarding vlan ala-1
configure vlan ala-2 ipaddress a.z.0.1 255.255.255.0
enable ipforwarding vlan ala-2
(Edited)
Photo of Taykin Izzet

Taykin Izzet , Employee

  • 2,924 Points 2k badge 2x thumb
Thank you for providing that information. Were you also able to confirm whether the ports  come up in active link state and if so, work with a data connection?
Photo of Admin ZML

Admin ZML

  • 202 Points 100 badge 2x thumb
The ports doesnt come up in active link state.
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,016 Points 5k badge 2x thumb
Assuming you have powered or rebooted this node, I would suggest doing an RMA for the physical switch.  In some research it looks like a hardware issue. Let me know the disposition.  If you would like to proceed I can email outside of this forum and get that started. Let me know.

Bill
Photo of Admin ZML

Admin ZML

  • 202 Points 100 badge 2x thumb
How do we start up the RMA procedure?
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,016 Points 5k badge 2x thumb
You can either register and start the process online (support.extremenetworks.com) and select "enter online case management and register and proceed...  or you can call GTAC @ 800-998-2408 or 877-411-2561.
Photo of Admin ZML

Admin ZML

  • 202 Points 100 badge 2x thumb
Do you need to have an active contract. the switches arn't 1 year yet and the hardware is defect.
Photo of Ryan Mathews

Ryan Mathews, Alum

  • 8,988 Points 5k badge 2x thumb
Sorry you're having trouble with this unit.  The Summit X460G2's have a great warranty on them (you can check here http://www.extremenetworks.com/support/policies).

As Bill suggested, GTAC is standing by to assist.  You can either do this by submitting the RMA via self-service or contact us directly.

Either way, we'll get you on the path to resolving this and quickly get back to other pressing matters.
Photo of David Coglianese

David Coglianese, Embassador

  • 5,954 Points 5k badge 2x thumb
I see this message after rebooting a stack

could not clear eee stats Feature unavailable for slot 6: port 48

Is this error related to this discussion?

Thanks
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,096 Points 10k badge 2x thumb
Hi David,

I did a quick search internally, and I wasn't able to find anything that indicates that your error is related to the other EEE error.

If this error persists, or if you're seeing any other issues with that port, I'd suggest opening up a case with GTAC so we can take a closer look.

-Brandon
(Edited)
Photo of David Coglianese

David Coglianese, Embassador

  • 5,954 Points 5k badge 2x thumb
I will be in district tonight and plan to test the functionality of the port. I will update you as to what I find.