TELNET hangs after firmware update to 15.3.4.6 or 16.1.3.6

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)

We have experienced some errors that are preventing us from a full firmware update to several devices.  The primary error occurs when attempting to make a TELENT connection.  We are able to enter username and password, but then the session immediately hangs: 
no display, no cursor, no keyboard responses. 

The error occurs on multiple platforms while migrating from various versions of firmware to either v15.3.4.6 or v16.1.3.6.  Here are a sampling of some of the affected devices:

Equip Model      Current F/W       New F/W
x650-24x              12.3.3.6                15.3.4.6
x650-24x              12.3.4.12              15.3.4.6
x460-48t               15.7.1.4                16.1.3.6
x460-24x              12.5.4.5                16.1.3.6
x450-48t               12.5.4.5                15.3.4.6
x450-48t               12.0.3.16              15.3.4.6
x350-48t               12.0.3.16              15.3.4.6

We're not sure if there is a problem with the XOS, setting, etc.  The TELNET session hang DOES NOT OCCUR on all devices.  We have successfully updated approx 75 already, but had to stop the update process once this error was discovered.

We have approximately 80 more devices to update, to which afterwards, they’ll have the SSH xmod installed. 

We appreciate any help or input you can offer.

Thanks,

Bobby

Photo of Bobby Johnson

Bobby Johnson

  • 110 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
I could see out of some sample list of affected devices, you are trying to upgrade from 12.3 to 15.3 release or so. Actually from these releases of 12.3 or below if any can not be directly upgraded to the next major release. Rather it requires intermediate steps for upgrade from 12.3.x to 15.x.

Please find below the article showing the exact steps of upgrading the same:

https://gtacknowledge.extremenetworks.com/articles/Q_A/Upgrade-from-12-X-to-15-X
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Would like to add one more point here which i missed in my previous post. Apart from these 12.3 or lower release others can be directly upgraded though. But as you are saying few of them experiencing telnet error hence please make sure when upgrading x460 always get the ssh mod before you upgrade and enable telnet (if disabled) before the reboot.


If you need SSH, this article will help:

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-obtain-and-install-ssh-module/
Photo of Bobby Johnson

Bobby Johnson

  • 110 Points 100 badge 2x thumb
Well, that would probably be the problem.  In our previous update group, we didn't encounter such old firmware and the problem went undetected.  I will coordinate with one of our less used devices and try the step process, then provide feedback.
Thanks for your help.
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
No issues. You are always welcome. Please test them with some of your old spare devices and return to us with the possible feedback later with the result.
Photo of Bobby Johnson

Bobby Johnson

  • 110 Points 100 badge 2x thumb
I forgot to provide feedback:  Yes, the intermediate step was the solution.  Even though we were at 15.3.4.6, I update to 12.5.1.6, rebooted, the updated to 15.2.4.6, rebooted and everything worked fine.  Thanks for your help.