Telnet problems on VRRP virtual address

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I'm currently trying to take remote access (via telnet or SSH) on a virtual VRRP ip address that is shared by two x670v switches and it doesn't work.

To figure out the problem, I've also tried to access via physical address on the same LAN that is shared by the switches, and, of course, no problem.
The VRRP virtual IP address is also well configured (One switch Master and the second switch is Backup).

Somebody knows why it's not possible to take remote access on the master of the VRRP Virtual address or knows a work-around ?

Thanks in advance.
Photo of Fauriant Tristan

Fauriant Tristan

  • 384 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Pala, Zdenek

Pala, Zdenek, Employee

  • 9,160 Points 5k badge 2x thumb
If I am correct the VRRP standard does not allow the answer for services (including telnet) on virtual IP. The exclusion is if it is owner of the IP address.
Photo of Fauriant Tristan

Fauriant Tristan

  • 384 Points 250 badge 2x thumb
Are you sure of that ? Because on other manufacturers, VRRP implementation allows to make connections to the management plane of the Master of the Virtual address in pointing on the Virtual IP address.

And this Virtual has not to be part of the physical addresses of the Master router (as VRRP allows).

Detail: I'm using currently VRRPv2
Photo of Drew C.

Drew C., Community Manager

  • 38,610 Points 20k badge 2x thumb
I'm pretty sure that Zdenek is correct, but I can't find it in the RFC.  It could be worded in such a way that I'm missing it.  This behavior seems common across other vendors.

I believe the only way to make this work is to enable fabric routing mode, which has its own caveats.
http://documentation.extremenetworks.com/exos/EXOS_21_1/VRRP/c_fabric-routing-functionality.shtml

Edit: See Kevin's response below :)
(Edited)
Photo of Kevin Kim

Kevin Kim, Employee

  • 2,266 Points 2k badge 2x thumb
Please turn on accept mode for VRRP. It's set to off by default.

# configure vrrp vlan "v1100" vrid 10 accept-mode  
off             Do not accept packets addressed to the VRRP Virtual IP.
on              Accept packets addressed to the VRRP Virtual IP.
Photo of Fauriant Tristan

Fauriant Tristan

  • 384 Points 250 badge 2x thumb
Thanks you, it's exactly what I was looking for.