TO Stack or not to Stack that is the question?

  • 0
  • 1
  • Question
  • Updated 4 years ago
Create Date: Sep 12 2012 7:55AM

Hi

We have two x670's as our core with x460 / x440 as edge switches, I'm wondering whether to stack the x670's or to link them via uplink ports. the reason i ask. is yesterday we tested a link failure between the two x670's by removing the stacking cable, we hardly lost pings if at all, then reconnected and the slave / unit 2 rebooted itself. 

Is this normal i presume it had reconfigured itself as master during the link loss.

do you think we would be better linking these two swtiches via uplink ports instead.?

oxide

(from conrad_jones)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 12 2012 1:50PM

Hello OxideThat is not normal behavior. The slave switch should not reboot. I would recommend opening a call with TAC to see why it did that.As for to stack or not the main decision should be in the design. Stacking especially the 670 offers a high speed connection which is nice if there is a lot of traffic between nodes on both switches and of course it allows you to manage both switches as a virtual chassis. The down side is that if you need to upgrade the stack you will take down both switches. Having them independent requires lagging multiple ports together for a high speed connection and you loose the single management capability but you gain more redundancy as you can upgrade each one independently allowing higher network uptime and provides more redundancy as a two switch design using MLAG or ERPS with VRRP. If you don't have redundant connections from the edge to the core than all of the redundancy doesn't matter :)Hope that helps.P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 12 2012 4:49PM

hi pruso.

it is currently planned to have redundant links from core to edge as all is really required is duplicating the optic modules which although is a bit of cost isn't that much in the grand scheme of things.

and we already have dual 10gbe nics in the Servers .

so the plan is dual links to each cabinet into each x670
and dual links to all servers into each x670 

what i have been playing with today disabled stacking in the x670's and LAG'd them together. 

then playing with MLAG to the edge stacks, which didn't work properly i was getting a loop or something not work as i would lose partial communication between the two x670's, behaving differently for differentl vlans (bear in mind the default route was causing this probably) but thats something to do tommorow! 
(from conrad_jones)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 12 2012 5:21PM

In my opinion I would do two switches and not a stack. With the redundant links it just provides a much better network.If you need some assistance with the MLAG post your config maybe we can get it worked out.ThanksP

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 12 2012 5:54PM

i did have a few questions about MLAG.

in the concepts guide, it mentions creating the ISC. i already have two ports linking the two x670's for tagged vlan traffic, should i use this for ISC or should i use additional ports?
(from conrad_jones)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 12 2012 9:11PM

You can use that link but you have to assign those ports to a specific VLAN that will be the ISC. It is highly recommended that you have that connection between the two switches as a LAG group. If the ISC goes down that is very bad.P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 13 2012 8:59AM

hmmm,

the link between the two is lagged, but i have two spare DAC's and two spare ports on each, might as well dedicate it .

(from conrad_jones)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 13 2012 5:38PM

i basically ended up doing ISC for mlag on the existing link between the two switches as the concepts guide said to put the vlans transmitted over the mlag link on the isc link and they were already on the existing link.

but i increased the ISC from two port lag to four port lag!

where i was going wrong with the MLAG link was incorrectly reading  (skimming) the concepts guide and confusing steps for ISC for MLAG ports.

(from conrad_jones)

This conversation is no longer open for comments or replies.