Tunnel L2TPv3

  • 0
  • 1
  • Question
  • Updated 2 months ago
  • Answered
Hello,
I would like create a tunnel L2TPv3 between a rfs4000 and ap7522 but when i type a command sh l2tpv3 tunnel vlanxxx in rfs4000 controller. The controller write a result "error:could not fetch L2TPv3 stats"
nobody have a solution
Best regards
Photo of yohan vaisseau

yohan vaisseau

  • 240 Points 100 badge 2x thumb

Posted 2 months ago

  • 0
  • 1
Photo of Slava Dementyev

Slava Dementyev, Employee

  • 220 Points 100 badge 2x thumb
Hello Yohan,

L2TPv3 show command needs full tunnel name, which is unique per tunnel endpoint. You can see the name in the tunnel-summary, e.g.:
NX55#show l2tpv3 tunnel-summary
--------------------------------------------------------------------------------------------------------------------------
Sl No  Tunnel Name                                      Peer  Tunnel State                     Tunnel Mode  Estd/Total Sessions   Encapsulation Proto
-------------------------------------------------------------------------------------------------------------------------
 1     VLAN7-214-8533-sjc-1-0.0.0.0                     1     Established                      Active            1/1              IP
 2     VLAN7-215-8533-blr-1-0.0.0.0                     1     Established                      Active            1/1              IP
 3     VLAN7-219-8533-brq-1-0.0.0.0                     1     Established                      Active            1/1              IP
--------------------------------------------------------------------------------------------------------------------------
Total Number of Tunnels 3
then you can use this name to fetch detailed tunnel stats:
NX55#show l2tpv3 tunnel VLAN7-214-8533-sjc-1-0.0.0.0
-------------------------------------------------------------------------------
Tunnel Name : VLAN7-214-8533-sjc-1-0.0.0.0
  Control connection id : 12995412
  Peer Address : 10.33.44.10
  Local Address : 192.168.7.110
  Encapsulation Protocol : IP
  MTU : 1460
  Peer Host Name : 8533-sjc-1
  Peer Vendor Name : Extreme Networks
  Peer Control Connection ID : 4080736026
  Tunnel State : Established
  Tunnel Mode : Active
  Establishment Criteria : always
  Sequence number of the next msg to the peer : 2
  Expected sequence number of the next msg from the peer :6428
  Sequence number of the next msg expected by the peer : 2
  Retransmission count : 0
  Reconnection count : 0
  Uptime : 0 days 18 hours 9 minutes 32 seconds
  -------------------------------------------------------------------------------
  Session Name : VLAN7
    VLANs : 7
    Pseudo Wire Type : Ethernet_VLAN
    Serial number for the session : 217
    Local Session ID : 56286258
    Remote Session ID : 56112662
    Size of local cookie (0, 4 or 8 bytes) : 0
    First word of local cookie : 0
    Second word of local cookie : 0
    Size of remote cookie (0, 4 or 8 bytes) : 0
    First word of remote cookie : 0
    Second word of remote cookie : 0
    Session state : Established
    Remote End ID : 7
    Trunk Session : 1
    Native VLAN tagged : Enabled
    Native VLAN ID :
    Egress rate limit : Disabled
    Ingress rate limit : Disabled
    Number of packets received : 2494
    Number of bytes received : 156612
    5 minute input rate : 14.72 bps
    Number of packets sent : 640429
    Number of bytes sent : 56754428
    5 minute output rate : 7.1 Kbps
    Number of packets dropped : 0
Hope this helps
Slava
Photo of yohan vaisseau

yohan vaisseau

  • 240 Points 100 badge 2x thumb
thank' s Slava for your response

But when i type command sh l2tpv3 tunnel-summary





Photo of Slava Dementyev

Slava Dementyev, Employee

  • 220 Points 100 badge 2x thumb
this means you either a) dont have any tunnel configured or b) none of the endpoints (APs) are able to reach your RFS and establish a tunnel. Please share your config
Photo of yohan vaisseau

yohan vaisseau

  • 240 Points 100 badge 2x thumb
this a config of my ap 7522


and this is config of my controller

rfs4000 B4-C7-99-F9-B7-DD
 use profile default-rfs4000
 use rf-domain default
 hostname rfs4000-F9B7DD
 license AP DEFAULT-6AP-LICENSE
 license AAP xxxxxxx
 license ADSEC DEFAULT-ADV-SEC-LICENSE
 ip default-gateway 172.26.1.254
 interface ge1
  switchport mode trunk
  switchport trunk native vlan 1
  no switchport trunk native tagged
  switchport trunk allowed vlan 1,119,2100
 interface vlan119
  ip address 172.26.1.48/24
 logging on
 logging console warnings
 logging buffered warnings
 l2tpv3 tunnel vlan119
  peer 1 hostname any router-id any
  no local-ip-address
  mtu 1460
  use l2tpv3-policy default
  session vlan119 pseudowire-id 119 traffic-source vlan 119
  no hostname
  no router-id
  establishment-criteria cluster-master
  no use critical-resource
  no fast-failover


Photo of Slava Dementyev

Slava Dementyev, Employee

  • 220 Points 100 badge 2x thumb
you dont have any cluster configured, do you? 

In that case change "establishment-criteria" from cluster-master to always under RFS tunnel configuration. Otherwise RFS will never bring the tunnel UP, since it is not part of any cluster.

are you testing with one AP and one RFS? Could you share full confg, and not just snippets, please?
Photo of yohan vaisseau

yohan vaisseau

  • 240 Points 100 badge 2x thumb
with the change "establishment-criteria" from always the tunnel is established.But the ap7522  do not download the conf on rfs4000