Two extreme switch can ping each other

  • 0
  • 1
  • Problem
  • Updated 7 months ago
  • Solved
Good day all

I have been looking around if this has been ask and answer it seems I can’t find any.

I have a problem with two extreme switch they can’t ping each other I have confing truck port 48  to connect each other but when I plung my laptop on access port 2 I can ping the switch.

 

Please see my configuration below maybe I’m doing wrong please assist.

Core sw

create vlan mangr tag 901

configure vlan mangr add ports 2 untagged

configure vlan mangr add ports 48 tag

configure vlan mangr ipaddress 10.248.111.2 255.255.255.0

enable ipforwarding vlan mangr

 

sw1

 

create vlan mangr tag 901

configure mangr add ports 48 tag

configure mangr add ports 2 untagged

configure mangr ipaddress 10.248.111.10/24

enable iproute 10.248.111.2 vr VR-Default

enable ipforwarding vlan mangr

configure iproute add 10.248.111.2 

Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hello Sivuyile

From what it looks like this is a straight Layer 2 VLAN.  Both switches are on the same IP Subnet.

When you say they can't ping one another are you doing that from the CLI?  If so what is the error you are seeing?  Are you pining from the station on the switch?

When you ping from the CLI you need to put the VR in the ping.  So use the command ping vr vr-d 10.248.111.2 and see what happens.

Thanks
P
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi Paul

That is correct,  i was ping from CLI... meaning if Im  ping from CLI  i must use this command like this  ping 10.248.111.2 vr vr-default ??

Thanks 
Photo of Mrxlazuardin

Mrxlazuardin

  • 1,534 Points 1k badge 2x thumb
Hi Sivuyile,

Without specifying the VR, the default VR for Ping on CLI is VR-Mgmt (Management VR) via dedicated management port.

Best regards,
Photo of Drew C.

Drew C., Community Manager

  • 39,166 Points 20k badge 2x thumb
The default virtual router for ping is VR-Default, not VR-Mgmt.
Photo of Mrxlazuardin

Mrxlazuardin

  • 1,534 Points 1k badge 2x thumb
Hi Drew,

Thank you for your correction. My mistake is thinking that Ping will have same behavior with SSH/Telnet.

Best regards,
(Edited)
Photo of Mel78, CISSP, ECE

Mel78, CISSP, ECE

  • 1,044 Points 1k badge 2x thumb
These 3 statements are unnecessary since they are all on the same subnet.

enable iproute 10.248.111.2 vr VR-Default

enable ipforwarding vlan mangr

configure iproute add 10.248.111.2 


I assume you connect port 48 of both switch links as a IEE 802.1Q trunk.

I would always enable loopback on the vlan on both switches. So that the vlan mangr is always active even when there are no active ports.

enable loopback-mode vlan mangr

Then you can try to ping again.

Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi Wong 

The reason I added configure iproute add 10.248.111.2 on switch 2 I need switch to use core-sw to route out the traffic inside core-sw there is other vlans and IP address

Thanks  
Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
Hi Sivuyile,

I'm considering the diagram and configuration as follows (since the ping is on the same vlan, you don't need to add route or enable ipforwarding. Unless you want to communicate across vlans):




Core sw
create vlan mangr tag 901
configure mangr add ports 48 tag
configure mangr add ports 2 untagged
configure mangr ipaddress 10.248.111.2/24

sw1
create vlan mangr tag 901
configure mangr add ports 48 tag
configure mangr add ports 2 untagged
configure mangr ipaddress 10.248.111.10/24


If you can ping from PC to the switch, you should check the uplink status.
  1. show port 48 configuration no-refresh <= Check if the port is up and using correct negotiation parameters
  2. show fdb vlan mangr <= Check if the neighbor MAC address is listed. You can confirm the switch MAC address using the command "show switch"
Also, please share the switch model and EXOS version.
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi Henrique 

Thanks for the diagram , Sw1 need to use core-sw to communicate with other vlans. On sw1 I have configure mangr vlan with ip address and configure two vlans without assigning IP address and those vlans to get routing they must use core-sw

Sw3.5 # ping 10.248.111.2 vr vr-default                          ^
%% Invalid input detected at '^' marker.

Sw3.1 # show version Switch      : 800618-00-08  Rev 8.0 BootROM: 1.0.1.7    IMG: 21.1.1.4  
PSU-1       : Internal Power Supply  
PSU-2       :

Image   : ExtremeXOS version 21.1.1.4 21.1.1.4-patch1-2 by release-manager
          on Fri Apr 15 12:41:44 EDT 2016
BootROM : 1.0.1.7
Diagnostics : 5.3


Thanks 
Siva
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,284 Points 10k badge 2x thumb
The invalid input comes from the fact that vr must be specified before the IP. Check that your ports 48 are tagged on both sides.
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
What are you using to make this diagram 
Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
Visio 2013
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Thanks each any everyone of u guys who assist me it is working now.   and More thanks to Henrique for the diagram it did help.

Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
Hi Sivuyile, we are glad to help.

Could you please share what changes has fixed the issue? Just to have that information in this thread.

Thanks.
Photo of Peter

Peter

  • 988 Points 500 badge 2x thumb
if you're using X440G2, you should use "show config"...
maybe than you can see the problem, when I'm right...

On X440G2 with XOS21.1.1.4-patch1-2, there is a bug, that prevent port from forwarding pakets...
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi Henrique


first issue was on my pings from the switch to another switch i use this command :ping ping vr "VR-Default" x.x.x.x

second step I clean up my configuration use the sample configures as follow :


Core sw
create vlan mangr tag 901
configure mangr add ports 48 tag
configure mangr ipaddress 10.248.111.2/24

sw1
create vlan mangr tag 901
configure mangr add ports 48 tag
configure mangr ipaddress 10.248.111.10/24

and both switch where able to ping each other .

Thanks 

Siv
Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
Perfect! Thanks for sharing.
Photo of Elena Madrigal

Elena Madrigal

  • 514 Points 500 badge 2x thumb
Hello. I have a similar issue. I have two X690 with version 22.3.1.4 22.3.1.4-patch1-4 conected by a SFP fiber on a 10G port.(also i tried with RJ 45) The port in both side are up ,and i learn MACs of the other side, and i can see information  of the other side  via CDP and lldp.all right except i cant ping  via Vlan1 and VR-default!!
Also i conect an N7 to one X690 to test. And i can ping it without any problem the  X690 and N7, If a put a laptop conected to the X690 i can ping it without problem. The issue is only beetween x690 switchs.
I have create another VLAN for test different of vlan1
Sw1
create vlan TEST1 tag 901
configure TEST1 add ports 1:46 tag
configure TEST1 ipaddress 192.168.1.2/24
Sw2
create vlan TEST1 tag 901
configure TEST1 add ports 1:46 tag
configure TEST1 ipaddress 192.168.1.1/24
The switch can ping itself but cant ping each other

¿Any idea?