Unable to transfer pcap file via SCP

  • 0
  • 2
  • Problem
  • Updated 11 months ago
  • Solved
  • (Edited)
Hey there,

I'm trying to transfer a pcap file from an X770 to my PC using SCP2 but I'm unable to do it.
TFTP is not an option since it's unreliable and has failed multiple times during transfer.
Tried also by connecting to the switch via SFTP but can't seem to access anything except the /config folder.

Please advise.

Thanks!

---

X770-02.29 # scp vr "VR-Default" "/usr/local/tmp/2016-03-03_09-49-39_rx_tx.pcap" admin@192.168.152.1:2016-03-03_09-49-39_rx_tx.pcap
Error: Local file name cannot contain '~' or '/' character.

X770-02.30 # scp vr "VR-Default" 2016-03-03_09-49-39_rx_tx.pcap admin@192.168.152.1:2016-03-03_09-49-39_rx_tx.pcap
Upload /config/2016-03-03_09-49-39_rx_tx.pcap to
admin@192.168.152.1's password:

Connected to 192.168.152.1.
stat /config/2016-03-03_09-49-39_rx_tx.pcap: No such file or directory

X770-02.31 # pwd
/usr/local/tmp

X770-02.32 # ls
-rwxr-xr-x    1 root     root     11012687 Mar  3 10:33 2016-03-03_09-49-39_rx_tx.pcap

Image   : ExtremeXOS version 16.1.2.14
Photo of Petar Mustur

Petar Mustur

  • 102 Points 100 badge 2x thumb
  • confused

Posted 2 years ago

  • 0
  • 2
Photo of Chad Smith

Chad Smith, Senior Escalation Support Engineer

  • 5,620 Points 5k badge 2x thumb
Official Response
Petar,

It seems SCP is only copying from the /usr/local/cfg directory and will not allow you to enter a different directory.  Can you try copying the file (with cp) to /usr/local/cfg and then transferring from there?

cd /usr/local/cfg
cp /usr/local/tmp/2016-03-03_09-49-39_rx_tx.pcap /usr/local/cfg/2016-03-03_09-49-39_rx_tx.pcap
scp vr "VR-Default" 2016-03-03_09-49-39_rx_tx.pcap admin@192.168.152.1:2016-03-03_09-49-39_rx_tx.pcap
(Edited)