Unable to upgrade firmware in Management Center on a single switch

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I've added three X440 switches to my new installation of Management Center.  I am in full control of them with SNMP and CLI credentials.  Management Center successfully backs up their configurations.



When I select one of the switches to upgrade firmware (I know, they are already on the latest version), I get the normal dialog window:



...except, if I try to do that with the last switch I added, here called Silverdale, WA:



No difference exists between this and the other two switches.  How can I manage the firmware on this switch using Management Center?
Photo of Jesse Ohlsson

Jesse Ohlsson

  • 680 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,932 Points 20k badge 2x thumb
Could you please provide a screenshot of the following two windows...

- in Inventory manager select the affected switch - I'd like to see the info in the right "general" tab
- then select the "image information" tab and post that also
Photo of Jesse Ohlsson

Jesse Ohlsson

  • 680 Points 500 badge 2x thumb
Ronald, I can't run the legacy java based applications.  What are you seeking?
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,932 Points 20k badge 2x thumb
I'd check if the devices have the same attributes set.... i.e. green check for firmware download.

Photo of Jesse Ohlsson

Jesse Ohlsson

  • 680 Points 500 badge 2x thumb
Ronald, I'm not sure you're understanding me.  I simply can't run the java-based legacy applications, inventory manager being one of those.  What you've captured there is a screenshot of Inventory Manager.  I know this, because I've used NetSight since 2007.

I'm trying to find the equivalent place to do this in Management Center's web GUI.
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,932 Points 20k badge 2x thumb
I fully understand, I've just answered your question ..."What are you seeking?

If that isn't possible because the client doesn't support/allow Java I've no clue where to find the same information in EMC - might be that this is one function that isn't yet implemented in the browser view.
Photo of Jesse Ohlsson

Jesse Ohlsson

  • 680 Points 500 badge 2x thumb
Yes, I'll have to find where that's done in Management Center.
Photo of Thomas, Frank

Thomas, Frank, Employee

  • 1,902 Points 1k badge 2x thumb
Hit the set Config button next to assigned image for the web view of that screen.
Photo of Jesse Ohlsson

Jesse Ohlsson

  • 680 Points 500 badge 2x thumb
Frank,

I have to refer you back to this image which I posted above:



On that one switch only, I can't get as far as the screenshot you posted.
Photo of Jesse Ohlsson

Jesse Ohlsson

  • 680 Points 500 badge 2x thumb
Sadly, the solution was to delete the device from Management Center, and then add it again.  I tried rediscovering it, to no avail.

But, after I added it again, the firmware upgrade process starts normally.