Upgrading XOS on 440-24p

  • 0
  • 1
  • Question
  • Updated 4 years ago
Hi,

I'm having some trouble connecting from my switch to my Laptop in order to perform a software upgrade.

I can't ping outbound from the switch using PING VR VR-DEFAULT, I receive 100% loss.
If I try to connect to a TFTP server using TFTP VR VR-DEFAULT I receive an error message stating that there is an invalid input under the V of VR-DEFAULT

Can confirm that both devices are on the same subnet as I can ping from laptop and connect using HTTP

I have also tried using Management port but that is showing as 'DOWN'

Any suggestions? 
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hey Jason can you do a show VLAN command for me and post it?

Thanks
p
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb

Hey Paul,

Details as requested.


H1.1 # show Vlan
---------------------------------------------------------------------------------------------
Name            VID  Protocol Addr       Flags                       Proto  Ports  Virtual
                                                                            Active router
                                                                            /Total
---------------------------------------------------------------------------------------------
admin           10   ----------------------------------------------- ANY    0 /1   VR-Default
curriculum      20   ----------------------------------------------- ANY    0 /1   VR-Default
Default         1    10.121.20.58   /24  ------------T-------------- ANY    1 /3   VR-Default
hotspot         60   ----------------------------------------------- ANY    0 /1   VR-Default
Mgmt            4095 ----------------------------------------------- ANY    0 /1   VR-Mgmt
---------------------------------------------------------------------------------------------
Flags : (B) BFD Enabled, (c) 802.1ad customer VLAN, (C) EAPS Control VLAN,
        (d) NetLogin Dynamically created VLAN, (D) VLAN Admin Disabled,
        (e) CES Configured, (E) ESRP Enabled, (f) IP Forwarding Enabled,
        (F) Learning Disabled, (i) ISIS Enabled, (I) Inter-Switch Connection VLAN for MLAG,
        (k) PTP Configured, (l) MPLS Enabled, (L) Loopback Enabled,
        (m) IPmc Forwarding Enabled, (M) Translation Member VLAN or Subscriber VLAN,
        (n) IP Multinetting Enabled, (N) Network Login VLAN, (o) OSPF Enabled,
        (O) Flooding Disabled, (p) PIM Enabled, (P) EAPS protected VLAN,
        (r) RIP Enabled, (R) Sub-VLAN IP Range Configured,
        (s) Sub-VLAN, (S) Super-VLAN, (t) Translation VLAN or Network VLAN,
        (T) Member of STP Domain, (v) VRRP Enabled, (V) VPLS Enabled, (W) VPWS Enabled

Total number of VLAN(s) : 5
H1.2 #

 

Thanks mate,

 

J.

Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Thanks Jason ok can you do a show default as well as the IP you are pinging
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
Try the below options
1.Enable Ipforwarding and try tftp download image from another vlan.
Reason:might be problem in current  vlan.
2.Assign another ip address to a new vlan and try uploading
3.Make sure no acl's are blocking TFTP.
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb

Hi,

H1.1 # show default
VLAN Interface with name Default created by user
        Admin State:    Enabled         Tagging:        802.1Q Tag 1
        Description:    None
        Virtual router: VR-Default
        IPv4 Forwarding: Disabled
        Primary IP    : 10.121.20.58/24
        IPv6 Forwarding: Disabled
        IPv6:           None
        STPD:           s0(Disabled,Auto-bind)
        Protocol:       Match all unfiltered protocols
        Loopback:       Disabled
        NetLogin:       Disabled
        QosProfile:     None configured
        Egress Rate Limit Designated Port: None configured
        Flood Rate Limit QosProfile:       None configured
        Ports:   3.       (Number of active ports=1)
           Untag:      22,    *23,     24
        Flags:    (*) Active, (!) Disabled, (g) Load Sharing port
                  (b) Port blocked on the vlan, (m) Mac-Based port
                  (a) Egress traffic allowed for NetLogin
                  (u) Egress traffic unallowed for NetLogin
                  (t) Translate VLAN tag for Private-VLAN
                  (s) Private-VLAN System Port, (L) Loopback port
                  (e) Private-VLAN End Point Port
                  (x) VMAN Tag Translated port
                  (G) Multi-switch LAG Group port

H1.2 # ping vr vr-default 10.121.20.89
Ping(ICMP) 10.121.20.89: 4 packets, 8 data bytes, interval 1 second(s).

--- 10.121.20.89 ping statistics ---
4 packets transmitted, 0 packets received, 100% loss
round-trip min/avg/max = 0/0/0 ms
H1.3 #


Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hey Jason. Well everything looks great. Can you ping from the device to the switch or can you have another PC on that VLAN and ping to and from that PC. As for the TFTP problem the command for the virtual router uses the -V not vroom so it looks like TFTP -v -g

P
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb
OK.

Thanks for looking in to this for me. I can ping the switch but I am directly connected via an inband port. I havent put the switch on the network yet as this device will be the 2nd unit in a stack that I am hoping to configure. Therefore I wanted to update the software to same version as the stack 'master' before proceeding, hence the TFTP requirement.

So will my syntax be TFTP -v -g default 10.121.20.58 (somehow that doesn't look right)

Thanks for your help mate.

J. 
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
download image <tftpip> exosversion vr vr-default 
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb
Thanks Pathiban.

Much appreciated.
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
TFTP get /put command is to send or receive config and policy files .
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb
Ok. Thanks for the advice. The syntax Parthiban gave me above worked a treat and the switch has now upgraded its software.

Now I'm going to try and create a stack ;-)

Thanks for your help chaps.
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hey John sorry I types my last reply from my phone and it didn't come across correctly. Looks like Parthiban got everything set for you.

Let us know if there are any other questions.

P
Photo of Jason Short

Jason Short

  • 390 Points 250 badge 2x thumb
Hi Paul,

Everything seems good so far.

I do have a question regarding stacking. 1 node in use and the 2nd node is what I have been working on today.
It looks like I can invoke the Easy Setup Procedure to create the stack, if I do this does it wipe the existing configuration of the node that is currently in use or does it append to the existing configuration?

Thanks,


J
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
I would recommend doing a fresh configuration as you are installing a stack for the first time.
If it was an existing stack and you are adding an unit or replacing an RMA unit ,you can follow the steps mentioned in concepts guide in section replacing a node in stack [very clear].

In current scenario:
Check the exos version is same for both the standalone switches.
They both must be in same partition.
Connect the stacking cables and do easy setup.
Reconfigure the stack for vlans and ip's.
As these are low end models ,there might be many vlans and couple of ip's for managing switch.
This reconfig shouldnt be a tedious task.
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
Its little difficult to mention all the options in here.
15.6 Concepts guide page 136 has details.
Still there are questions or you get stuck please fell free to update.